summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES5
-rw-r--r--MANIFEST.in4
-rw-r--r--README5
-rw-r--r--blinker/__init__.py2
-rw-r--r--docs/source/Makefile5
-rw-r--r--setup.py2
6 files changed, 14 insertions, 9 deletions
diff --git a/CHANGES b/CHANGES
index 55b0df1..2901b50 100644
--- a/CHANGES
+++ b/CHANGES
@@ -5,9 +5,10 @@ Blinker Changelog
Version 0.9
-----------
-Not yet released
+Released February 26, 2010
- Added ``Signal.temporarily_connected_to`` context manager
+- Docs! Sphinx docs, project web site.
Version 0.8
@@ -19,4 +20,4 @@ Released February 14, 2010
- Extracted from flatland.util.signals
- Added Python 2.4 compatability
- Added nearly functionaly Python 3.1 compatability (everything except
- connecting to instance methods seems to work.) \ No newline at end of file
+ connecting to instance methods seems to work.)
diff --git a/MANIFEST.in b/MANIFEST.in
index fb833e0..3af4058 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -3,4 +3,6 @@ include README
include AUTHORS
include CHANGES
recursive-include tests *py
-
+recursive-include docs/source *rst *py
+recursive-include docs/text *txt
+recursive-include docs/html *html *txt *png *css *js *inv
diff --git a/README b/README
index 707f634..f4e5de2 100644
--- a/README
+++ b/README
@@ -30,8 +30,9 @@ sent by any sender.
Changelog Summary
-----------------
-0.9 (development)
- - Sphinx docs
+0.9 (February 26, 2010)
+ - Sphinx docs, project website
+ - Added ``with a_signal.temporarily_connected_to(receiver): ...`` support
0.8 (February 14, 2010)
- First independent release separate from flatland
diff --git a/blinker/__init__.py b/blinker/__init__.py
index 173c544..d12a4a7 100644
--- a/blinker/__init__.py
+++ b/blinker/__init__.py
@@ -17,4 +17,4 @@ __all__ = [
]
-__version__ = '0.9dev'
+__version__ = '0.9'
diff --git a/docs/source/Makefile b/docs/source/Makefile
index 78a8488..57b9bfe 100644
--- a/docs/source/Makefile
+++ b/docs/source/Makefile
@@ -5,9 +5,11 @@
SPHINXOPTS =
SPHINXBUILD = sphinx-build
VERSION ?= tip
+RELEASE ?= $(VERSION)
# Internal variables.
-ALLSPHINXOPTS = -d ../doctrees $(SPHINXOPTS) .
+ALLSPHINXOPTS = -D version=$(VERSION) -D release=$(RELEASE) \
+ -d ../doctrees $(SPHINXOPTS) .
help:
@echo "Please use \`make <target>' where <target> is one of"
@@ -49,5 +51,4 @@ website:
mkdir -p ../website ../doctrees
$(SPHINXBUILD) -b discorporate \
-D html_theme=discorporate \
- -D version=$(VERSION) \
$(ALLSPHINXOPTS) ../website
diff --git a/setup.py b/setup.py
index 09a2a6d..009ba66 100644
--- a/setup.py
+++ b/setup.py
@@ -13,7 +13,7 @@ setup(name="blinker",
keywords='signal emit events broadcast',
long_description=readme,
license='MIT License',
- url='http://bitbucket.org/jek/blinker/',
+ url='http://discorporate.us/projects/Blinker/',
classifiers=[
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',