summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2017-01-23 10:19:01 +0100
committerArmin Rigo <arigo@tunes.org>2017-01-23 10:19:01 +0100
commitcdadb3a2a03135691a9b94a60074b8a84bcfa5e4 (patch)
treeff1d084b2c6e50b5f94b7ae6d5a4cea55da0aeb4
parenta4a555495357afdeacb4837d947add4ff56d0d76 (diff)
downloadcffi-cdadb3a2a03135691a9b94a60074b8a84bcfa5e4.tar.gz
bump version number to 1.10.0
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py6
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/_embedding.h2
-rw-r--r--doc/source/conf.py4
-rw-r--r--doc/source/installation.rst2
-rw-r--r--setup.py2
-rw-r--r--testing/cffi0/test_version.py2
8 files changed, 12 insertions, 12 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index 22e18a0..902f0ad 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -2,7 +2,7 @@
#include <Python.h>
#include "structmember.h"
-#define CFFI_VERSION "1.9.2"
+#define CFFI_VERSION "1.10.0"
#ifdef MS_WIN32
#include <windows.h>
diff --git a/c/test_c.py b/c/test_c.py
index 0ef0327..0cd4a16 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -12,9 +12,9 @@ from _cffi_backend import _testfunc, _get_types, _get_common_types, __version__
# ____________________________________________________________
import sys
-assert __version__ == "1.9.2", ("This test_c.py file is for testing a version"
- " of cffi that differs from the one that we"
- " get from 'import _cffi_backend'")
+assert __version__ == "1.10.0", ("This test_c.py file is for testing a version"
+ " of cffi that differs from the one that we"
+ " get from 'import _cffi_backend'")
if sys.version_info < (3,):
type_or_class = "type"
mandatory_b_prefix = ''
diff --git a/cffi/__init__.py b/cffi/__init__.py
index 8f4c6dd..e2e70fd 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -4,8 +4,8 @@ __all__ = ['FFI', 'VerificationError', 'VerificationMissing', 'CDefError',
from .api import FFI
from .error import CDefError, FFIError, VerificationError, VerificationMissing
-__version__ = "1.9.2"
-__version_info__ = (1, 9, 2)
+__version__ = "1.10.0"
+__version_info__ = (1, 10, 0)
# The verifier module file names are based on the CRC32 of a string that
# contains the following version number. It may be older than __version__
diff --git a/cffi/_embedding.h b/cffi/_embedding.h
index 2f69c77..1142183 100644
--- a/cffi/_embedding.h
+++ b/cffi/_embedding.h
@@ -233,7 +233,7 @@ static int _cffi_initialize_python(void)
f = PySys_GetObject((char *)"stderr");
if (f != NULL && f != Py_None) {
PyFile_WriteString("\nFrom: " _CFFI_MODULE_NAME
- "\ncompiled with cffi version: 1.9.2"
+ "\ncompiled with cffi version: 1.10.0"
"\n_cffi_backend module: ", f);
modules = PyImport_GetModuleDict();
mod = PyDict_GetItemString(modules, "_cffi_backend");
diff --git a/doc/source/conf.py b/doc/source/conf.py
index f7246fd..75da487 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -45,9 +45,9 @@ copyright = u'2012-2015, Armin Rigo, Maciej Fijalkowski'
# built documents.
#
# The short X.Y version.
-version = '1.9'
+version = '1.10'
# The full version, including alpha/beta/rc tags.
-release = '1.9.2'
+release = '1.10.0'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 9356880..e48e046 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -51,7 +51,7 @@ Requirements:
Download and Installation:
-* http://pypi.python.org/packages/source/c/cffi/cffi-1.9.2.tar.gz
+* http://pypi.python.org/packages/source/c/cffi/cffi-1.10.0.tar.gz
- MD5: ...
diff --git a/setup.py b/setup.py
index 6df3f3c..c93c8ef 100644
--- a/setup.py
+++ b/setup.py
@@ -183,7 +183,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='1.9.2',
+ version='1.10.0',
packages=['cffi'] if cpython else [],
package_data={'cffi': ['_cffi_include.h', 'parse_c_type.h',
'_embedding.h']}
diff --git a/testing/cffi0/test_version.py b/testing/cffi0/test_version.py
index 7485db1..c6324bc 100644
--- a/testing/cffi0/test_version.py
+++ b/testing/cffi0/test_version.py
@@ -28,7 +28,7 @@ def test_doc_version():
content = open(p).read()
#
v = cffi.__version__
- assert ("version = '%s'\n" % v[:3]) in content
+ assert ("version = '%s'\n" % v[:4]) in content
assert ("release = '%s'\n" % v) in content
def test_doc_version_file():