summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2016-11-12 14:44:59 +0100
committerArmin Rigo <arigo@tunes.org>2016-11-12 14:44:59 +0100
commitd2bef3fdea7bcb4e2b001c1b057500c64d3b4320 (patch)
tree863f89c3245ac728775c081721a4c55b3515521e
parentdec808b186500660ffe680062d69765b7c1d137f (diff)
downloadcffi-d2bef3fdea7bcb4e2b001c1b057500c64d3b4320.tar.gz
update to 1.9.1
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/_embedding.h2
-rw-r--r--doc/source/conf.py2
-rw-r--r--doc/source/installation.rst8
-rw-r--r--setup.py2
7 files changed, 11 insertions, 11 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index 3d3c55c..a111e04 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -2,7 +2,7 @@
#include <Python.h>
#include "structmember.h"
-#define CFFI_VERSION "1.9.0"
+#define CFFI_VERSION "1.9.1"
#ifdef MS_WIN32
#include <windows.h>
diff --git a/c/test_c.py b/c/test_c.py
index b83d544..3960e9f 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -12,7 +12,7 @@ from _cffi_backend import _testfunc, _get_types, _get_common_types, __version__
# ____________________________________________________________
import sys
-assert __version__ == "1.9.0", ("This test_c.py file is for testing a version"
+assert __version__ == "1.9.1", ("This test_c.py file is for testing a version"
" of cffi that differs from the one that we"
" get from 'import _cffi_backend'")
if sys.version_info < (3,):
diff --git a/cffi/__init__.py b/cffi/__init__.py
index 5c84197..4529ee9 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -4,8 +4,8 @@ __all__ = ['FFI', 'VerificationError', 'VerificationMissing', 'CDefError',
from .api import FFI, CDefError, FFIError
from .ffiplatform import VerificationError, VerificationMissing
-__version__ = "1.9.0"
-__version_info__ = (1, 9, 0)
+__version__ = "1.9.1"
+__version_info__ = (1, 9, 1)
# The verifier module file names are based on the CRC32 of a string that
# contains the following version number. It may be older than __version__
diff --git a/cffi/_embedding.h b/cffi/_embedding.h
index 422b0a5..e8cc8a0 100644
--- a/cffi/_embedding.h
+++ b/cffi/_embedding.h
@@ -233,7 +233,7 @@ static int _cffi_initialize_python(void)
f = PySys_GetObject((char *)"stderr");
if (f != NULL && f != Py_None) {
PyFile_WriteString("\nFrom: " _CFFI_MODULE_NAME
- "\ncompiled with cffi version: 1.9.0"
+ "\ncompiled with cffi version: 1.9.1"
"\n_cffi_backend module: ", f);
modules = PyImport_GetModuleDict();
mod = PyDict_GetItemString(modules, "_cffi_backend");
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 7ae9120..149f981 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -47,7 +47,7 @@ copyright = u'2012-2015, Armin Rigo, Maciej Fijalkowski'
# The short X.Y version.
version = '1.9'
# The full version, including alpha/beta/rc tags.
-release = '1.9.0'
+release = '1.9.1'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 933717e..89f50a8 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -51,13 +51,13 @@ Requirements:
Download and Installation:
-* http://pypi.python.org/packages/source/c/cffi/cffi-1.9.0.tar.gz
+* http://pypi.python.org/packages/source/c/cffi/cffi-1.9.1.tar.gz
- - MD5: 3806f3b4e093fa84fda0651e53bd09f1
+ - MD5: ...
- - SHA: 0060819964edb18ae542cb6a04eb5fee3e8bd961
+ - SHA: ...
- - SHA256: ef98626610d1c9b409da6529970a584cf88f0d1e9f3e902a569eddc1332d7864
+ - SHA256: ...
* Or grab the most current version from the `Bitbucket page`_:
``hg clone https://bitbucket.org/cffi/cffi``
diff --git a/setup.py b/setup.py
index 577d2b8..97cc8ad 100644
--- a/setup.py
+++ b/setup.py
@@ -153,7 +153,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='1.9.0',
+ version='1.9.1',
packages=['cffi'] if cpython else [],
package_data={'cffi': ['_cffi_include.h', 'parse_c_type.h',
'_embedding.h']}