summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2016-11-02 10:30:12 +0100
committerArmin Rigo <arigo@tunes.org>2016-11-02 10:30:12 +0100
commite5799f1a577bb0e6877dc7e036720f7304797407 (patch)
tree4f8896aa09aac088fb99e27efa8d97086be4100f
parentb3cd9a6e908b54f9a0c9c59a6744bcdbcc2e4d00 (diff)
downloadcffi-e5799f1a577bb0e6877dc7e036720f7304797407.tar.gz
Bump version number to 1.9.0
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/_embedding.h2
-rw-r--r--doc/source/conf.py4
-rw-r--r--doc/source/installation.rst2
-rw-r--r--setup.py2
7 files changed, 9 insertions, 9 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index 34a5bda..6c1237f 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -2,7 +2,7 @@
#include <Python.h>
#include "structmember.h"
-#define CFFI_VERSION "1.8.4"
+#define CFFI_VERSION "1.9.0"
#ifdef MS_WIN32
#include <windows.h>
diff --git a/c/test_c.py b/c/test_c.py
index a50085f..b83d544 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -12,7 +12,7 @@ from _cffi_backend import _testfunc, _get_types, _get_common_types, __version__
# ____________________________________________________________
import sys
-assert __version__ == "1.8.4", ("This test_c.py file is for testing a version"
+assert __version__ == "1.9.0", ("This test_c.py file is for testing a version"
" of cffi that differs from the one that we"
" get from 'import _cffi_backend'")
if sys.version_info < (3,):
diff --git a/cffi/__init__.py b/cffi/__init__.py
index 532454d..5c84197 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -4,8 +4,8 @@ __all__ = ['FFI', 'VerificationError', 'VerificationMissing', 'CDefError',
from .api import FFI, CDefError, FFIError
from .ffiplatform import VerificationError, VerificationMissing
-__version__ = "1.8.4"
-__version_info__ = (1, 8, 4)
+__version__ = "1.9.0"
+__version_info__ = (1, 9, 0)
# The verifier module file names are based on the CRC32 of a string that
# contains the following version number. It may be older than __version__
diff --git a/cffi/_embedding.h b/cffi/_embedding.h
index 0b2fae1..de39b6c 100644
--- a/cffi/_embedding.h
+++ b/cffi/_embedding.h
@@ -233,7 +233,7 @@ static int _cffi_initialize_python(void)
f = PySys_GetObject((char *)"stderr");
if (f != NULL && f != Py_None) {
PyFile_WriteString("\nFrom: " _CFFI_MODULE_NAME
- "\ncompiled with cffi version: 1.8.4"
+ "\ncompiled with cffi version: 1.9.0"
"\n_cffi_backend module: ", f);
modules = PyImport_GetModuleDict();
mod = PyDict_GetItemString(modules, "_cffi_backend");
diff --git a/doc/source/conf.py b/doc/source/conf.py
index a908f51..7ae9120 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -45,9 +45,9 @@ copyright = u'2012-2015, Armin Rigo, Maciej Fijalkowski'
# built documents.
#
# The short X.Y version.
-version = '1.8'
+version = '1.9'
# The full version, including alpha/beta/rc tags.
-release = '1.8.4'
+release = '1.9.0'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 568341f..9e5df9d 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -51,7 +51,7 @@ Requirements:
Download and Installation:
-* http://pypi.python.org/packages/source/c/cffi/cffi-1.8.4.tar.gz
+* http://pypi.python.org/packages/source/c/cffi/cffi-1.9.0.tar.gz
- MD5: ...
diff --git a/setup.py b/setup.py
index f8fcb7a..577d2b8 100644
--- a/setup.py
+++ b/setup.py
@@ -153,7 +153,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='1.8.4',
+ version='1.9.0',
packages=['cffi'] if cpython else [],
package_data={'cffi': ['_cffi_include.h', 'parse_c_type.h',
'_embedding.h']}