summaryrefslogtreecommitdiff
path: root/demo
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2012-07-15 14:57:00 +0200
committerArmin Rigo <arigo@tunes.org>2012-07-15 14:57:00 +0200
commit7c856aa8302e88017a2ad51aabb47446cc6d1941 (patch)
tree50b73310b7a4adc47b7cec52c0d3f2173c9b273c /demo
parent2847dec3e3213fefbc3f6e326941d5cc72c553cc (diff)
downloadcffi-7c856aa8302e88017a2ad51aabb47446cc6d1941.tar.gz
Yay, it works: a minimal example of setup.py to install a Python module
together with the custom C extension module generated by CFFI.
Diffstat (limited to 'demo')
-rw-r--r--demo/setup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/demo/setup.py b/demo/setup.py
new file mode 100644
index 0000000..5d6ddcf
--- /dev/null
+++ b/demo/setup.py
@@ -0,0 +1,11 @@
+#
+# A minimal example of setup.py to install a Python module
+# together with the custom C extension module generated by CFFI.
+#
+
+from distutils.core import setup
+from distutils.extension import Extension
+import bsdopendirtype
+
+setup(py_modules=['bsdopendirtype'],
+ ext_modules=[bsdopendirtype.ffi.verifier.get_extension()])