summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2020-08-08 12:08:31 +0200
committerArmin Rigo <arigo@tunes.org>2020-08-08 12:08:31 +0200
commit7b625cda8c6ee5ad2a55b559aa5a9f92c3714eec (patch)
tree2f26841e1093c8fe750c6c86ebdb5b0c72360d06 /doc
parent913767b6eff974f650722041eefc7f2076c09b18 (diff)
downloadcffi-7b625cda8c6ee5ad2a55b559aa5a9f92c3714eec.tar.gz
'bitbucket => heptapod' for most links
Diffstat (limited to 'doc')
-rw-r--r--doc/source/cdef.rst2
-rw-r--r--doc/source/embedding.rst2
-rw-r--r--doc/source/installation.rst30
-rw-r--r--doc/source/ref.rst4
-rw-r--r--doc/source/using.rst4
-rw-r--r--doc/source/whatsnew.rst22
6 files changed, 24 insertions, 40 deletions
diff --git a/doc/source/cdef.rst b/doc/source/cdef.rst
index dd56a7e..b1bbb8d 100644
--- a/doc/source/cdef.rst
+++ b/doc/source/cdef.rst
@@ -590,7 +590,7 @@ above`_ as primitive (so ``extern long long a[5];`` and ``extern int64_t a[5]``
different declarations). The reason for that is detailed in `a comment
about an issue.`__
-.. __: https://bitbucket.org/cffi/cffi/issues/265/cffi-doesnt-allow-creating-pointers-to#comment-28406958
+.. __: https://foss.heptapod.net/pypy/cffi/-/issues/265#note_50393
ffibuilder.compile() etc.: compiling out-of-line modules
diff --git a/doc/source/embedding.rst b/doc/source/embedding.rst
index 181249c..f26a0f2 100644
--- a/doc/source/embedding.rst
+++ b/doc/source/embedding.rst
@@ -380,7 +380,7 @@ inaccuracies in this paragraph or better ways to do things.)
``dlopen("libpythonX.Y.so", RTLD_LAZY|RTLD_GLOBAL)``, which will
force ``libpythonX.Y.so`` to be loaded first.
-.. __: https://bitbucket.org/cffi/cffi/issues/264/
+.. __: https://foss.heptapod.net/pypy/cffi/-/issues/264
Using multiple CFFI-made DLLs
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 8dab03f..6b38cd2 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -65,7 +65,7 @@ Download and Installation:
* ``python setup.py install`` or ``python setup_base.py install``
(should work out of the box on Linux or Windows; see below for
- `MacOS X`_ or `Windows 64`_.)
+ `MacOS X`_.)
* running the tests: ``py.test c/ testing/`` (if you didn't
install cffi yet, you need first ``python setup_base.py build_ext -f
@@ -82,9 +82,9 @@ Demos:
ultimate reference is given by the tests, notably
`testing/cffi1/test_verify1.py`_ and `testing/cffi0/backend_tests.py`_.
-.. _`demo`: https://bitbucket.org/cffi/cffi/src/default/demo
-.. _`testing/cffi1/test_verify1.py`: https://bitbucket.org/cffi/cffi/src/default/testing/cffi1/test_verify1.py
-.. _`testing/cffi0/backend_tests.py`: https://bitbucket.org/cffi/cffi/src/default/testing/cffi0/backend_tests.py
+.. _`demo`: https://foss.heptapod.net/pypy/cffi/-/tree/branch/default/demo
+.. _`testing/cffi1/test_verify1.py`: https://foss.heptapod.net/pypy/cffi/-/blob/branch/default/testing/cffi1/test_verify1.py
+.. _`testing/cffi0/backend_tests.py`: https://foss.heptapod.net/pypy/cffi/-/blob/branch/default/testing/cffi0/backend_tests.py
Platform-specific instructions
@@ -133,10 +133,10 @@ as described here_.
.. _here: http://superuser.com/questions/259278/python-2-6-1-pycrypto-2-3-pypi-package-broken-pipe-during-build
-Windows (regular 32-bit)
-++++++++++++++++++++++++
+Windows (32/64-bit)
++++++++++++++++++++
-Win32 works and is tested at least each official release.
+Win32 and Win64 work and are tested at least each official release.
The recommended C compiler compatible with Python 2.7 is this one:
http://www.microsoft.com/en-us/download/details.aspx?id=44266
@@ -150,22 +150,6 @@ For Python 3.4 and beyond:
https://www.visualstudio.com/en-us/downloads/visual-studio-2015-ctp-vs
-Windows 64
-++++++++++
-
-Win64 received very basic testing and we applied a few essential
-fixes in cffi 0.7. The comment above applies for Python 2.7 on
-Windows 64 as well. Please report any other issue.
-
-Note as usual that this is only about running the 64-bit version of
-Python on the 64-bit OS. If you're running the 32-bit version (the
-common case apparently), then you're running Win32 as far as we're
-concerned.
-
-.. _`issue 9`: https://bitbucket.org/cffi/cffi/issue/9
-.. _`Python issue 7546`: http://bugs.python.org/issue7546
-
-
Linux and OS/X: UCS2 versus UCS4
++++++++++++++++++++++++++++++++
diff --git a/doc/source/ref.rst b/doc/source/ref.rst
index 9aaed7a..1348ed6 100644
--- a/doc/source/ref.rst
+++ b/doc/source/ref.rst
@@ -459,7 +459,7 @@ destructors will be called in a random order. If you need a particular
order, see the discussion in `issue 340`__.
.. __: http://bugs.python.org/issue31105
-.. __: https://bitbucket.org/cffi/cffi/issues/340/resources-release-issues
+.. __: https://foss.heptapod.net/pypy/cffi/-/issues/340
.. _ffi-new-handle:
@@ -731,7 +731,7 @@ example::
raise IndexError("index too large!")
...
-.. __: https://bitbucket.org/cffi/cffi/issues/233/
+.. __: https://foss.heptapod.net/pypy/cffi/-/issues/233
.. _ffi-getctype:
diff --git a/doc/source/using.rst b/doc/source/using.rst
index beb3f92..fc65a4f 100644
--- a/doc/source/using.rst
+++ b/doc/source/using.rst
@@ -787,7 +787,7 @@ The ``extern "Python"`` functions cannot be variadic for now. This
may be implemented in the future. (`This demo`__ shows how to do it
anyway, but it is a bit lengthy.)
-.. __: https://bitbucket.org/cffi/cffi/src/default/demo/extern_python_varargs.py
+.. __: https://foss.heptapod.net/pypy/cffi/-/blob/branch/default/demo/extern_python_varargs.py
Each corresponding Python callback function is defined with the
``@ffi.def_extern()`` decorator. Be careful when writing this
@@ -896,7 +896,7 @@ ffi.callback() and the result is the same.
to refactor the involved code so that it no longer uses ``ffi.callback()``.
.. __: https://github.com/pyca/pyopenssl/issues/596
-.. __: https://bitbucket.org/cffi/cffi/issues/391/
+.. __: https://foss.heptapod.net/pypy/cffi/-/issues/391
.. __: https://bugzilla.redhat.com/show_bug.cgi?id=1249685
Warning: like ffi.new(), ffi.callback() returns a cdata that has
diff --git a/doc/source/whatsnew.rst b/doc/source/whatsnew.rst
index 4b5199b..446a28a 100644
--- a/doc/source/whatsnew.rst
+++ b/doc/source/whatsnew.rst
@@ -55,7 +55,7 @@ v1.13.2
* re-release because the Linux wheels came with an attached version of libffi
that was very old and buggy (`issue #432`_).
-.. _`issue #432`: https://bitbucket.org/cffi/cffi/issues/432/
+.. _`issue #432`: https://foss.heptapod.net/pypy/cffi/-/issues/432
@@ -74,8 +74,8 @@ v1.13.1
* fixed `issue #427`_ where a multithreading mistake in the embedding logic
initialization code would cause deadlocks on CPython 3.7.
-.. _`issue #429`: https://bitbucket.org/cffi/cffi/issues/429/
-.. _`issue #427`: https://bitbucket.org/cffi/cffi/issues/427/
+.. _`issue #429`: https://foss.heptapod.net/pypy/cffi/-/issues/429
+.. _`issue #427`: https://foss.heptapod.net/pypy/cffi/-/issues/427
v1.13
@@ -173,7 +173,7 @@ v1.12
to 1 byte instead of 4).
.. __: cdef.html#pkgconfig
-.. _`issue #362`: https://bitbucket.org/cffi/cffi/issues/362/
+.. _`issue #362`: https://foss.heptapod.net/pypy/cffi/-/issues/362
v1.11.5
@@ -205,10 +205,10 @@ v1.11.5
concerned about virtualenv: pass ``define_macros=[("Py_LIMITED_API",
None)]`` as a keyword to the ``ffibuilder.set_source()`` call.
-.. _`Issue #345`: https://bitbucket.org/cffi/cffi/issues/345/
-.. _`Issue #350`: https://bitbucket.org/cffi/cffi/issues/350/
-.. _`Issue #358`: https://bitbucket.org/cffi/cffi/issues/358/
-.. _`Issue #357`: https://bitbucket.org/cffi/cffi/issues/357/
+.. _`Issue #345`: https://foss.heptapod.net/pypy/cffi/-/issues/345
+.. _`Issue #350`: https://foss.heptapod.net/pypy/cffi/-/issues/350
+.. _`Issue #358`: https://foss.heptapod.net/pypy/cffi/-/issues/358
+.. _`Issue #357`: https://foss.heptapod.net/pypy/cffi/-/issues/357
v1.11.4
@@ -221,7 +221,7 @@ v1.11.4
``foo.cp36-win32.pyd``, to make it clear that they are regular
CPython modules depending on ``python36.dll``.
-.. _`Issue #355`: https://bitbucket.org/cffi/cffi/issues/355/
+.. _`Issue #355`: https://foss.heptapod.net/pypy/cffi/-/issues/355
v1.11.3
@@ -310,9 +310,9 @@ v1.11
that are *slower* to call than the API mode does. For some reason it
is often thought to be faster. It is not!
-.. __: https://bitbucket.org/cffi/cffi/issues/321/cffi-191-segmentation-fault-during-self
+.. __: https://foss.heptapod.net/pypy/cffi/-/issues/321
.. __: ref.html#ffi-gc
-.. __: https://bitbucket.org/cffi/cffi/issues/320/improve-memory_pressure-management
+.. __: https://foss.heptapod.net/pypy/cffi/-/issues/320
.. __: http://bugs.python.org/issue31105