summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2014-03-15 07:53:51 +0100
committerArmin Rigo <arigo@tunes.org>2014-03-15 07:53:51 +0100
commit0952058970483b12647e45c7b50bb65eb33a5b4f (patch)
tree8c89a82ccef6d867a06da9599e4607a157c02745 /setup.py
parent9ca8bc58d9431087a569fd026393ea1b48ff4384 (diff)
downloadcffi-0952058970483b12647e45c7b50bb65eb33a5b4f.tar.gz
Use the word 'Note' to make it sound less ominous
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index c3a6402..86fbd5e 100644
--- a/setup.py
+++ b/setup.py
@@ -43,9 +43,9 @@ def _ask_pkg_config(resultlist, option, result_prefix='', sysroot=False):
def ask_supports_thread():
if sys.platform == "darwin":
- sys.stderr.write("OS/X: confusion between 'cc' versus 'gcc'")
- sys.stderr.write(" (see issue 123)\n")
- sys.stderr.write("will not use '__thread' in the C code\n")
+ sys.stderr.write("Note: will not use '__thread' in the C code\n")
+ sys.stderr.write("This is for OS/X-specific reasons: confusion "
+ "between 'cc' versus 'gcc' (see issue 123)\n")
return
import distutils.errors
from distutils.ccompiler import new_compiler
@@ -53,8 +53,8 @@ def ask_supports_thread():
try:
compiler.compile(['c/check__thread.c'])
except distutils.errors.CompileError:
- sys.stderr.write("the above error message can be safely ignored;\n")
- sys.stderr.write("will not use '__thread' in the C code\n")
+ sys.stderr.write("Note: will not use '__thread' in the C code\n")
+ sys.stderr.write("The above error message can be safely ignored\n")
else:
define_macros.append(('USE__THREAD', None))
try: