summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2015-04-30 01:22:32 +0200
committerArmin Rigo <arigo@tunes.org>2015-04-30 01:22:32 +0200
commit4db697afd405aa72ce40b532935299e88e188f35 (patch)
treebb49f186e9ba762dcb2a76ddc5916fd2c6dc39e7 /setup.py
parent083de8d165c6c2bcf952f0fb19e0fbf8c24c31da (diff)
parentf935a21b2edf14aa2df8379f8256ffcc3f4f0f9e (diff)
downloadcffi-4db697afd405aa72ce40b532935299e88e188f35.tar.gz
hg merge default
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2b60ffd..cb66267 100644
--- a/setup.py
+++ b/setup.py
@@ -19,7 +19,7 @@ def _ask_pkg_config(resultlist, option, result_prefix='', sysroot=False):
p = subprocess.Popen([pkg_config, option, 'libffi'],
stdout=subprocess.PIPE)
except OSError as e:
- if e.errno != errno.ENOENT:
+ if e.errno not in [errno.ENOENT, errno.EACCES]:
raise
else:
t = p.stdout.read().decode().strip()