summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2017-08-25 10:35:58 +0200
committerArmin Rigo <arigo@tunes.org>2017-08-25 10:35:58 +0200
commitc4fa8373cc466474a44d9525aaac0e8a3f137ef0 (patch)
tree9a1ed7173195f222fb2d7f1e2bc013390b8443ee /setup.py
parent863229bebb82c0eac1e87a93490ce0e2bc64cb67 (diff)
downloadcffi-c4fa8373cc466474a44d9525aaac0e8a3f137ef0.tar.gz
Improve error message
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 8 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index c4777d6..b6cdd9e 100644
--- a/setup.py
+++ b/setup.py
@@ -44,11 +44,14 @@ def _ask_pkg_config(resultlist, option, result_prefix='', sysroot=False):
def no_working_compiler_found():
sys.stderr.write("""
- No working compiler found, or bogus compiler options
- passed to the compiler from Python's distutils module.
- See the error messages above.
- (If they are about -mno-fused-madd and you are on OS/X 10.8,
- see http://stackoverflow.com/questions/22313407/ .)\n""")
+ No working compiler found, or bogus compiler options passed to
+ the compiler from Python's standard "distutils" module. See
+ the error messages above. Likely, the problem is not related
+ to CFFI but generic to the setup.py of any Python package that
+ tries to compile C code. (Hints: on OS/X 10.8, for errors about
+ -mno-fused-madd see http://stackoverflow.com/questions/22313407/
+ Otherwise, see https://wiki.python.org/moin/CompLangPython or
+ the IRC channel #python on irc.freenode.net.)\n""")
sys.exit(1)
def get_config():