summaryrefslogtreecommitdiff
path: root/testing
diff options
context:
space:
mode:
authorArmin Rigo <armin.rigo@gmail.com>2021-09-17 07:31:59 +0000
committerArmin Rigo <armin.rigo@gmail.com>2021-09-17 07:31:59 +0000
commit4d7e8223ff1059ec5ba363b97d521d80b64dd182 (patch)
treeb5893a12b8d619fe4a5000b15be02e66441bb97e /testing
parent1a13928f1e22b2ec0dc19816d97a7e40bdad0ed0 (diff)
parent808edcadfa4a33f25c746c4a8e0e3da622a744d2 (diff)
downloadcffi-4d7e8223ff1059ec5ba363b97d521d80b64dd182.tar.gz
Merge branch 'branch/setuptools_test_macos_fix' into 'branch/default'
Fix setuptools tests for macos See merge request pypy/cffi!108
Diffstat (limited to 'testing')
-rw-r--r--testing/cffi0/test_zintegration.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/cffi0/test_zintegration.py b/testing/cffi0/test_zintegration.py
index 4cce595..ce925b8 100644
--- a/testing/cffi0/test_zintegration.py
+++ b/testing/cffi0/test_zintegration.py
@@ -77,7 +77,10 @@ def really_run_setup_and_program(dirname, venv_dir_and_paths, python_snippet):
env = os.environ.copy()
env['PYTHONPATH'] = paths
subprocess.check_call((vp, 'setup.py', 'clean'), env=env)
- subprocess.check_call((vp, 'setup.py', 'install'), env=env)
+ # there's a setuptools/easy_install bug that causes this to fail when the build/install occur together and
+ # we're in the same directory with the build (it tries to look up dependencies for itself on PyPI);
+ # subsequent runs will succeed because this test doesn't properly clean up the build- use pip for now.
+ subprocess.check_call((vp, '-m', 'pip', 'install', '.'), env=env)
subprocess.check_call((vp, str(python_f)), env=env)
finally:
os.chdir(olddir)