summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/_embedding.h2
-rw-r--r--doc/source/conf.py2
-rw-r--r--doc/source/installation.rst8
-rw-r--r--setup.py2
7 files changed, 11 insertions, 11 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index 79ee015..6d139ad 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -2,7 +2,7 @@
#include <Python.h>
#include "structmember.h"
-#define CFFI_VERSION "1.12.0"
+#define CFFI_VERSION "1.12.1"
#ifdef MS_WIN32
#include <windows.h>
diff --git a/c/test_c.py b/c/test_c.py
index df2143d..b0f1a70 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -12,7 +12,7 @@ from _cffi_backend import _testfunc, _get_types, _get_common_types, __version__
# ____________________________________________________________
import sys
-assert __version__ == "1.12.0", ("This test_c.py file is for testing a version"
+assert __version__ == "1.12.1", ("This test_c.py file is for testing a version"
" of cffi that differs from the one that we"
" get from 'import _cffi_backend'")
if sys.version_info < (3,):
diff --git a/cffi/__init__.py b/cffi/__init__.py
index 157a215..0e35518 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -5,8 +5,8 @@ from .api import FFI
from .error import CDefError, FFIError, VerificationError, VerificationMissing
from .error import PkgConfigError
-__version__ = "1.12.0"
-__version_info__ = (1, 12, 0)
+__version__ = "1.12.1"
+__version_info__ = (1, 12, 1)
# The verifier module file names are based on the CRC32 of a string that
# contains the following version number. It may be older than __version__
diff --git a/cffi/_embedding.h b/cffi/_embedding.h
index fa2afca..a1a7c86 100644
--- a/cffi/_embedding.h
+++ b/cffi/_embedding.h
@@ -221,7 +221,7 @@ static int _cffi_initialize_python(void)
if (f != NULL && f != Py_None) {
PyFile_WriteString("\nFrom: " _CFFI_MODULE_NAME
- "\ncompiled with cffi version: 1.12.0"
+ "\ncompiled with cffi version: 1.12.1"
"\n_cffi_backend module: ", f);
modules = PyImport_GetModuleDict();
mod = PyDict_GetItemString(modules, "_cffi_backend");
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 582aaf5..be80ea4 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -47,7 +47,7 @@ copyright = u'2012-2018, Armin Rigo, Maciej Fijalkowski'
# The short X.Y version.
version = '1.12'
# The full version, including alpha/beta/rc tags.
-release = '1.12.0'
+release = '1.12.1'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 47cea63..6f3c078 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -52,13 +52,13 @@ Download and Installation:
* https://pypi.python.org/pypi/cffi
-* Checksums of the "source" package version 1.12.0:
+* Checksums of the "source" package version 1.12.1:
- - MD5: 8e3c92fb5a7b5e32390882dd8ed32275
+ - MD5: ...
- - SHA: 270cc6e3b4873c617647d05aaa6fd1302a1f0071
+ - SHA: ...
- - SHA256: 08090454ff236239e583a9119d0502a6b9817594c0a3714dd1d8593f2350ba11
+ - SHA256: ...
* Or grab the most current version from the `Bitbucket page`_:
``hg clone https://bitbucket.org/cffi/cffi``
diff --git a/setup.py b/setup.py
index b72bfc2..b2a1a6c 100644
--- a/setup.py
+++ b/setup.py
@@ -198,7 +198,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='1.12.0',
+ version='1.12.1',
packages=['cffi'] if cpython else [],
package_data={'cffi': ['_cffi_include.h', 'parse_c_type.h',
'_embedding.h', '_cffi_errors.h']}