summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.md8
1 files changed, 8 insertions, 0 deletions
diff --git a/README.md b/README.md
index 542a0f5..4df4405 100644
--- a/README.md
+++ b/README.md
@@ -15,7 +15,15 @@ Contact
[Mailing list](https://groups.google.com/forum/#!forum/python-cffi)
+Testing/development tips
+------------------------
+
To run tests under CPython, run::
+ pip install pytest # if you don't have py.test already
python setup.py build_ext -f -i
py.test c/ test/
+
+If you run in another directory (either the tests or another program),
+you should use the environment variable ``PYTHONPATH=/path`` to point
+to the location that contains the ``_cffi_backend.so`` just compiled.