summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index fc8d705..8216851 100644
--- a/setup.py
+++ b/setup.py
@@ -150,7 +150,10 @@ if COMPILE_LIBFFI:
for filename in _filenames)
else:
if 'darwin' in sys.platform and macosx_deployment_target() >= (10, 15):
- # use libffi from Mac OS SDK
+ # use libffi from Mac OS SDK if we're targetting 10.15 (including
+ # on arm64). This libffi is safe against the crash-after-fork
+ # issue described in _cffi_backend.c. Also, arm64 uses a different
+ # ABI for calls to vararg functions as opposed to regular functions.
extra_compile_args += ['-iwithsysroot/usr/include/ffi']
define_macros += [('CFFI_TRUST_LIBFFI', '1'),
('HAVE_FFI_PREP_CIF_VAR', '1')]