summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/_embedding.h2
-rw-r--r--doc/source/conf.py4
-rw-r--r--doc/source/installation.rst8
-rw-r--r--setup.py2
7 files changed, 12 insertions, 12 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index bcbe45a..1c8c6e7 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -2,7 +2,7 @@
#include <Python.h>
#include "structmember.h"
-#define CFFI_VERSION "1.12.3"
+#define CFFI_VERSION "1.13.0"
#ifdef MS_WIN32
#include <windows.h>
diff --git a/c/test_c.py b/c/test_c.py
index ed3491d..0a83485 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -14,7 +14,7 @@ from _cffi_backend import _testfunc, _get_types, _get_common_types, __version__
# ____________________________________________________________
import sys
-assert __version__ == "1.12.3", ("This test_c.py file is for testing a version"
+assert __version__ == "1.13.0", ("This test_c.py file is for testing a version"
" of cffi that differs from the one that we"
" get from 'import _cffi_backend'")
if sys.version_info < (3,):
diff --git a/cffi/__init__.py b/cffi/__init__.py
index 0224a15..36ca8ba 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -5,8 +5,8 @@ from .api import FFI
from .error import CDefError, FFIError, VerificationError, VerificationMissing
from .error import PkgConfigError
-__version__ = "1.12.3"
-__version_info__ = (1, 12, 3)
+__version__ = "1.13.0"
+__version_info__ = (1, 13, 0)
# The verifier module file names are based on the CRC32 of a string that
# contains the following version number. It may be older than __version__
diff --git a/cffi/_embedding.h b/cffi/_embedding.h
index 30842c1..d11b62a 100644
--- a/cffi/_embedding.h
+++ b/cffi/_embedding.h
@@ -224,7 +224,7 @@ static int _cffi_initialize_python(void)
if (f != NULL && f != Py_None) {
PyFile_WriteString("\nFrom: " _CFFI_MODULE_NAME
- "\ncompiled with cffi version: 1.12.3"
+ "\ncompiled with cffi version: 1.13.0"
"\n_cffi_backend module: ", f);
modules = PyImport_GetModuleDict();
mod = PyDict_GetItemString(modules, "_cffi_backend");
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 3c76b9a..afc31e2 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -45,9 +45,9 @@ copyright = u'2012-2018, Armin Rigo, Maciej Fijalkowski'
# built documents.
#
# The short X.Y version.
-version = '1.12'
+version = '1.13'
# The full version, including alpha/beta/rc tags.
-release = '1.12.3'
+release = '1.13.0'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index f4e27ca..4765e8f 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -52,13 +52,13 @@ Download and Installation:
* https://pypi.python.org/pypi/cffi
-* Checksums of the "source" package version 1.12.3:
+* Checksums of the "source" package version 1.13.0:
- - MD5: 35ad1f9e1003cac9404c1493eb10d7f5
+ - MD5: ...
- - SHA: ccc49cf31bc3f4248f45b9ec83685e4e8090a9fa
+ - SHA: ...
- - SHA256: 041c81822e9f84b1d9c401182e174996f0bae9991f33725d059b771744290774
+ - SHA256: ...
* Or grab the most current version from the `Bitbucket page`_:
``hg clone https://bitbucket.org/cffi/cffi``
diff --git a/setup.py b/setup.py
index 1891187..00b1f5d 100644
--- a/setup.py
+++ b/setup.py
@@ -198,7 +198,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='1.12.3',
+ version='1.13.0',
packages=['cffi'] if cpython else [],
package_data={'cffi': ['_cffi_include.h', 'parse_c_type.h',
'_embedding.h', '_cffi_errors.h']}