summaryrefslogtreecommitdiff
path: root/.flake8
diff options
context:
space:
mode:
authorDavid Lord <davidism@gmail.com>2023-01-19 16:41:06 -0800
committerDavid Lord <davidism@gmail.com>2023-01-19 16:42:12 -0800
commit742a5521c4e219c8413a9a0478f752b54ad6d9ea (patch)
tree9d8e4e3bfe046205496b1d6c16540a2c95222a70 /.flake8
parentcba52fa76135af2edf46c154203b47106f898eb3 (diff)
downloadclick-742a5521c4e219c8413a9a0478f752b54ad6d9ea.tar.gz
switch to pyproject.toml
Diffstat (limited to '.flake8')
-rw-r--r--.flake825
1 files changed, 25 insertions, 0 deletions
diff --git a/.flake8 b/.flake8
new file mode 100644
index 0000000..c53aceb
--- /dev/null
+++ b/.flake8
@@ -0,0 +1,25 @@
+[flake8]
+extend-select =
+ # bugbear
+ B
+ # bugbear opinions
+ B9
+ # implicit str concat
+ ISC
+extend-ignore =
+ # slice notation whitespace, invalid
+ E203
+ # line length, handled by bugbear B950
+ E501
+ # bare except, handled by bugbear B001
+ E722
+ # zip with strict=, requires python >= 3.10
+ B905
+ # string formatting opinion, B028 renamed to B907
+ B028
+ B907
+# up to 88 allowed by bugbear B950
+max-line-length = 80
+per-file-ignores =
+ # __init__ exports names
+ src/click/__init__.py: F401