summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorDavid Lord <davidism@gmail.com>2021-02-15 18:22:21 -0800
committerDavid Lord <davidism@gmail.com>2021-02-15 18:39:05 -0800
commitd7fac6e16099005c642f4dcb71d84a091a787073 (patch)
tree841cd96ddf950ff08ca61ee0606718211e40dc7e /examples
parentea3bb6f1bf5db675f2dec0350f57e704da6ea00b (diff)
downloadclick-d7fac6e16099005c642f4dcb71d84a091a787073.tar.gz
always install colorama on Windows
Diffstat (limited to 'examples')
-rw-r--r--examples/colors/README2
-rw-r--r--examples/colors/colors.py5
-rw-r--r--examples/colors/setup.py6
-rw-r--r--examples/termui/setup.py6
4 files changed, 5 insertions, 14 deletions
diff --git a/examples/colors/README b/examples/colors/README
index 4b5b44f..7aec8ef 100644
--- a/examples/colors/README
+++ b/examples/colors/README
@@ -3,7 +3,7 @@ $ colors_
colors is a simple example that shows how you can
colorize text.
- For this to work on Windows, colorama is required.
+ Uses colorama on Windows.
Usage:
diff --git a/examples/colors/colors.py b/examples/colors/colors.py
index cb7af31..1d94417 100644
--- a/examples/colors/colors.py
+++ b/examples/colors/colors.py
@@ -23,9 +23,8 @@ all_colors = (
@click.command()
def cli():
- """This script prints some colors. If colorama is installed this will
- also work on Windows. It will also automatically remove all ANSI
- styles if data is piped into a file.
+ """This script prints some colors. It will also automatically remove
+ all ANSI styles if data is piped into a file.
Give it a try!
"""
diff --git a/examples/colors/setup.py b/examples/colors/setup.py
index 6d892dd..3e1a594 100644
--- a/examples/colors/setup.py
+++ b/examples/colors/setup.py
@@ -5,11 +5,7 @@ setup(
version="1.0",
py_modules=["colors"],
include_package_data=True,
- install_requires=[
- "click",
- # Colorama is only required for Windows.
- "colorama",
- ],
+ install_requires=["click"],
entry_points="""
[console_scripts]
colors=colors:cli
diff --git a/examples/termui/setup.py b/examples/termui/setup.py
index 7791bae..c1ac109 100644
--- a/examples/termui/setup.py
+++ b/examples/termui/setup.py
@@ -5,11 +5,7 @@ setup(
version="1.0",
py_modules=["termui"],
include_package_data=True,
- install_requires=[
- "click",
- # Colorama is only required for Windows.
- "colorama",
- ],
+ install_requires=["click"],
entry_points="""
[console_scripts]
termui=termui:cli