summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.md64
-rw-r--r--README.rst92
-rw-r--r--setup.py12
3 files changed, 100 insertions, 68 deletions
diff --git a/README.md b/README.md
deleted file mode 100644
index caec365..0000000
--- a/README.md
+++ /dev/null
@@ -1,64 +0,0 @@
-# $ click_
-
-[![Build status](https://ci.appveyor.com/api/projects/status/pjxh5g91jpbh7t84?svg=true)](https://ci.appveyor.com/project/tygerbytes/resourcefitness)
-
-## What's Click?
-
-Click is a Python package for creating beautiful command line interfaces
-in a composable way with as little code as necessary. It's the "Command
-Line Interface Creation Kit". It's highly configurable but comes with
-sensible defaults out of the box.
-
-It aims to make the process of writing command line tools quick and fun
-while also preventing any frustration caused by the inability to implement
-an intended CLI API.
-
-Click in three points:
- - arbitrary nesting of commands
- - automatic help page generation
- - supports lazy loading of subcommands at runtime
-
-## Example
-What does it look like? Here is an example of a simple Click program:
-```python
-import click
-
-@click.command()
-@click.option('--count', default=1, help='Number of greetings.')
-@click.option('--name', prompt='Your name',
- help='The person to greet.')
-def hello(count, name):
- """Simple program that greets NAME for a total of COUNT times."""
- for x in range(count):
- click.echo('Hello %s!' % name)
-
-if __name__ == '__main__':
- hello()
-```
-And what it looks like when run:
-```shell
-$ python hello.py --count=3
-Your name: John
-Hello John!
-Hello John!
-Hello John!
-```
-
-## Installation
-The installation process is easy and contained.
-```
-$ pip install Click
-```
-Or you can build from source.
-```
-$ git clone https://github.com/pallets/click.git
-$ python setup.py install
-```
-
-## Documentation
-
-Read the docs at http://click.pocoo.org/
-
-## Status
-
-This library is stable and active. Feedback is always welcome!
diff --git a/README.rst b/README.rst
new file mode 100644
index 0000000..07352ad
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,92 @@
+\$ click\_
+==========
+
+What's Click?
+-------------
+
+Click is a Python package for creating beautiful command line interfaces
+in a composable way with as little code as necessary. It's the "Command
+Line Interface Creation Kit". It's highly configurable but comes with
+sensible defaults out of the box.
+
+It aims to make the process of writing command line tools quick and fun
+while also preventing any frustration caused by the inability to implement
+an intended CLI API.
+
+Click in three points:
+ - arbitrary nesting of commands
+ - automatic help page generation
+ - supports lazy loading of subcommands at runtime
+
+
+Installing
+----------
+
+Install and update using `pip`_:
+
+.. code-block:: text
+
+ $ pip install click
+
+A Simple Example
+----------------
+
+What does it look like? Here is an example of a simple Click program:
+
+.. code-block:: python
+
+ import click
+
+ @click.command()
+ @click.option('--count', default=1, help='Number of greetings.')
+ @click.option('--name', prompt='Your name',
+ help='The person to greet.')
+ def hello(count, name):
+ """Simple program that greets NAME for a total of COUNT times."""
+ for x in range(count):
+ click.echo('Hello %s!' % name)
+
+ if __name__ == '__main__':
+ hello()
+
+And what it looks like when run:
+
+.. code-block:: text
+
+ $ python hello.py --count=3
+ Your name: John
+ Hello John!
+ Hello John!
+ Hello John!
+
+Donate
+------
+
+The Pallets organization develops and supports Flask and the libraries
+it uses. In order to grow the community of contributors and users, and
+allow the maintainers to devote more time to the projects, `please
+donate today`_.
+
+.. _please donate today: https://psfmember.org/civicrm/contribute/transact?reset=1&id=20
+
+
+Links
+-----
+
+* Website: https://www.palletsprojects.com/p/click/
+* Documentation: http://click.pocoo.org/
+* License: `BSD <https://github.com/pallets/click/blob/master/LICENSE>`_
+* Releases: https://pypi.org/project/click/
+* Code: https://github.com/pallets/click
+* Issue tracker: https://github.com/pallets/click/issues
+* Test status:
+
+ * Linux, Mac: https://travis-ci.org/pallets/click
+ * Windows: https://ci.appveyor.com/project/pallets/click
+
+* Test coverage: https://codecov.io/gh/pallets/click
+
+.. _WSGI: https://wsgi.readthedocs.io
+.. _Werkzeug: https://www.palletsprojects.com/p/werkzeug/
+.. _Jinja: https://www.palletsprojects.com/p/jinja/
+.. _pip: https://pip.pypa.io/en/stable/quickstart/
diff --git a/setup.py b/setup.py
index bc49da0..f762463 100644
--- a/setup.py
+++ b/setup.py
@@ -1,15 +1,18 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+import io
import re
-import ast
from setuptools import setup
_version_re = re.compile(r'__version__\s+=\s+(.*)')
-with open('click/__init__.py', 'rb') as f:
- version = str(ast.literal_eval(_version_re.search(
- f.read().decode('utf-8')).group(1)))
+with io.open('README.rst', 'rt', encoding='utf8') as f:
+ readme = f.read()
+with io.open('click/__init__.py', 'rt', encoding='utf8') as f:
+ version = re.search(r'__version__ = \'(.*?)\'', f.read()).group(1)
setup(
name='click',
@@ -19,6 +22,7 @@ setup(
author_email='armin.ronacher@active-4.com',
maintainer='Pallets team',
maintainer_email='contact@palletsprojects.com',
+ long_description=readme,
packages=['click'],
description='A simple wrapper around optparse for '
'powerful command line utilities.',