summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/dependabot.yml2
-rw-r--r--.pre-commit-config.yaml1
-rw-r--r--setup.cfg10
-rw-r--r--tox.ini2
4 files changed, 8 insertions, 7 deletions
diff --git a/.github/dependabot.yml b/.github/dependabot.yml
index a268177..bbd9645 100644
--- a/.github/dependabot.yml
+++ b/.github/dependabot.yml
@@ -2,7 +2,7 @@ version: 2
updates:
- package-ecosystem: "pip"
directory: "/requirements"
- target-branch: "3.0.x"
+ target-branch: "8.0.x"
versioning-strategy: "lockfile-only"
schedule:
interval: "monthly"
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 353ef89..609fdb9 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -1,4 +1,5 @@
ci:
+ autoupdate_branch: "8.0.x"
autoupdate_schedule: monthly
repos:
- repo: https://github.com/asottile/pyupgrade
diff --git a/setup.cfg b/setup.cfg
index 06474f8..47f7e5f 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -29,7 +29,7 @@ classifiers =
[options]
packages = find:
package_dir = = src
-include_package_data = true
+include_package_data = True
python_requires = >= 3.6
# Dependencies are in setup.py for GitHub's dependency graph.
@@ -42,14 +42,14 @@ filterwarnings =
error
[coverage:run]
-branch = true
+branch = True
source =
click
tests
[coverage:paths]
source =
- click
+ src
*/site-packages
[flake8]
@@ -57,7 +57,7 @@ source =
# E = pycodestyle errors
# F = flake8 pyflakes
# W = pycodestyle warnings
-# B9 = bugbear opinions,
+# B9 = bugbear opinions
# ISC = implicit str concat
select = B, E, F, W, B9, ISC
ignore =
@@ -72,7 +72,7 @@ ignore =
# up to 88 allowed by bugbear B950
max-line-length = 80
per-file-ignores =
- # __init__ module exports names
+ # __init__ exports names
src/click/__init__.py: F401
[mypy]
diff --git a/tox.ini b/tox.ini
index d1e4140..0275385 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py3{11,10,9,8,7,6},pypy37
+ py3{11,10,9,8,7,6},pypy3{8,7}
style
typing
docs