summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/tests.yaml6
-rw-r--r--tox.ini2
2 files changed, 1 insertions, 7 deletions
diff --git a/.github/workflows/tests.yaml b/.github/workflows/tests.yaml
index 0cd5fda..2291f44 100644
--- a/.github/workflows/tests.yaml
+++ b/.github/workflows/tests.yaml
@@ -23,7 +23,6 @@ jobs:
- {name: '3.7', python: '3.7', os: ubuntu-latest, tox: py37}
- {name: '3.6', python: '3.6', os: ubuntu-latest, tox: py36}
- {name: 'PyPy', python: pypy3, os: ubuntu-latest, tox: pypy3}
- - {name: Style, python: '3.9', os: ubuntu-latest, tox: style}
- {name: Docs, python: '3.9', os: ubuntu-latest, tox: docs}
steps:
- uses: actions/checkout@v2
@@ -43,11 +42,6 @@ jobs:
with:
path: ${{ steps.pip-cache.outputs.dir }}
key: pip|${{ runner.os }}|${{ matrix.python }}|${{ hashFiles('setup.py') }}|${{ hashFiles('requirements/*.txt') }}
- - name: cache pre-commit
- uses: actions/cache@v1
- with:
- path: ~/.cache/pre-commit
- key: pre-commit|${{ matrix.python }}|${{ hashFiles('.pre-commit-config.yaml') }}
if: matrix.tox == 'style'
- run: pip install tox
- run: tox -e ${{ matrix.tox }}
diff --git a/tox.ini b/tox.ini
index 9ec517b..2ca13c9 100644
--- a/tox.ini
+++ b/tox.ini
@@ -7,7 +7,7 @@ skip_missing_interpreters = true
[testenv]
deps = -r requirements/tests.txt
-commands = pytest --tb=short --basetemp={envtmpdir} {posargs}
+commands = pytest -v --tb=short --basetemp={envtmpdir} {posargs}
[testenv:style]
deps = pre-commit