summaryrefslogtreecommitdiff
path: root/demoapp
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2012-04-23 07:22:33 -0700
committerDoug Hellmann <doug.hellmann@dreamhost.com>2012-04-23 07:22:33 -0700
commit3a533e4f3f371e9d042534a6f0dbe39ec2e79c41 (patch)
treec26663c62f2eddf17853fb69f5a729d2e77bb7b7 /demoapp
parent4bdafd3b54ffd5edf83a2d92a0577cf39395f9c8 (diff)
downloadcliff-tablib-3a533e4f3f371e9d042534a6f0dbe39ec2e79c41.tar.gz
flesh out instructions for using the demo app
Diffstat (limited to 'demoapp')
-rw-r--r--demoapp/README.rst35
1 files changed, 25 insertions, 10 deletions
diff --git a/demoapp/README.rst b/demoapp/README.rst
index 89043a6..a510d1b 100644
--- a/demoapp/README.rst
+++ b/demoapp/README.rst
@@ -1,35 +1,50 @@
-Running demoapp
-===============
+=================
+ Running demoapp
+=================
Setup
-----
-First, you need to create a virtual environment and switch to it::
+First, you need to create a virtual environment and activate it.
+
+::
$ pip install virtualenv
$ virtualenv .venv
$ . .venv/bin/activate
+ (.venv)$
+
+Next, install ``cliff`` in the environment.
+
+::
+
+ (.venv)$ python setup.py install
+
+Now, install the demo application into the virtual environment.
-Now, install the demo into the virtual environment::
+::
- $ python setup.py install
+ (.venv)$ cd demoapp
+ (.venv)$ python setup.py install
Usage
-----
With cliff and the demo setup up, you can now play with it.
-Here are a list of the commands available::
+To see a list of commands availble, run::
- XXX
+ (.venv)$ cliffdemo --help
-Here is some example usage::
+To see help for an individual command, include the command name on the
+command line::
- XXX
+ (.venv)$ cliffdemo files --help
Cleaning Up
-----------
Finally, when done, deactivate your virtual environment::
- $ deactivate
+ (.venv)$ deactivate
+ $