summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorheavenshell <heavenshell.jp@gmail.com>2012-05-08 21:42:39 +0900
committerheavenshell <heavenshell.jp@gmail.com>2012-05-08 21:42:39 +0900
commit2ffa8496131fec1638b903fb9738be4eac597288 (patch)
tree53da5d00bd08b7fa002f664f656a162f8e022cbd /setup.py
parentdfe456fa6b6eadda8ba77fc74ad043e2b3f9d050 (diff)
downloadcliff-tablib-2ffa8496131fec1638b903fb9738be4eac597288.tar.gz
enable to use in Python2.6
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 13 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 5febd0e..b57ec73 100644
--- a/setup.py
+++ b/setup.py
@@ -21,6 +21,18 @@ try:
except IOError:
long_description = ''
+install_requires = ['distribute',
+ # disabled until OpenStack catches up 'PrettyTable>=0.6',
+ 'PrettyTable',
+ 'cmd2',
+ 'tablib',
+ ]
+try:
+ import argparse
+except ImportError:
+ install_requires.append('argparse')
+
+
##############################################################################
# find_package_data is an Ian Bicking creation.
@@ -145,12 +157,7 @@ setup(
provides=['cliff',
],
- install_requires=['distribute',
- # disabled until OpenStack catches up 'PrettyTable>=0.6',
- 'PrettyTable',
- 'cmd2',
- 'tablib',
- ],
+ install_requires=install_requires,
namespace_packages=[],
packages=find_packages(),