summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2012-05-06 20:06:17 -0400
committerDoug Hellmann <doug.hellmann@dreamhost.com>2012-05-06 20:06:17 -0400
commit6efada5b6a084e5e22e3b7a225375ff8132be255 (patch)
tree12075126f5e2bd3708ece4b1bbf995027b452320 /setup.py
parent2acfc3ce1e6d88a9acbd994360388927eb25c844 (diff)
downloadcliff-tablib-6efada5b6a084e5e22e3b7a225375ff8132be255.tar.gz
add yaml, json, and html formatters
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 28434ce..ff41d08 100644
--- a/setup.py
+++ b/setup.py
@@ -148,6 +148,7 @@ setup(
install_requires=['distribute',
'PrettyTable>=0.6',
'cmd2',
+ 'tablib',
],
namespace_packages=[],
@@ -165,6 +166,9 @@ setup(
'cliff.formatter.list': [
'table = cliff.formatters.table:TableFormatter',
'csv = cliff.formatters.commaseparated:CSVLister',
+ 'yaml = cliff.formatters.tablibformatters:YamlFormatter',
+ 'html = cliff.formatters.tablibformatters:HtmlFormatter',
+ 'json = cliff.formatters.tablibformatters:JsonFormatter',
],
'cliff.formatter.show': [
'table = cliff.formatters.table:TableFormatter',