summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..498d508
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,20 @@
+help:
+ @echo "release - package and upload a release"
+ @echo "sdist - package"
+ @echo "docs - generate HTML documentation"
+ @echo "clean - remove build artifacts"
+
+release: docs
+ python setup.py sdist upload
+
+sdist: docs
+ python setup.py sdist
+ ls -l dist
+
+clean:
+ rm -rf dist build *.egg-info
+ (cd docs && make clean)
+
+.PHONY: docs
+docs:
+ (cd docs && make clean html)