summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2013-04-02 15:55:58 -0400
committerDoug Hellmann <doug.hellmann@dreamhost.com>2013-04-02 15:55:58 -0400
commitdf52cc387dbc446350af717ee5a6e83cba351d92 (patch)
tree6926de01430c4aa1e6951d82884b85c7b160e405
parent80a2ee71216e35c201cf96c5f54a3bd626c1202d (diff)
downloadcliff-df52cc387dbc446350af717ee5a6e83cba351d92.tar.gz
Prepare 1.3.2 release1.3.2
Change-Id: I138c53d12577d9afe698759e1819132ba976c606 Signed-off-by: Doug Hellmann <doug.hellmann@dreamhost.com>
-rw-r--r--announce.rst16
-rw-r--r--docs/source/history.rst4
-rw-r--r--setup.py2
3 files changed, 14 insertions, 8 deletions
diff --git a/announce.rst b/announce.rst
index 0726834..4d9e4c7 100644
--- a/announce.rst
+++ b/announce.rst
@@ -1,5 +1,5 @@
========================================================================
- cliff -- Command Line Interface Formulation Framework -- version 1.3.1
+ cliff -- Command Line Interface Formulation Framework -- version 1.3.2
========================================================================
.. tags:: python cliff release DreamHost
@@ -11,11 +11,15 @@ other extensions.
What's New In This Release?
===========================
-- Sort list of commands in interactive help mode. (contributed by Ilya
- Shakhat)
-- Fix a dependency issue with PyParsing until the cmd2 package can
- release an update setting the version of its dependency based on the
- Python version.
+- Add ``convert_underscores`` parameter to ``CommandManager``
+ ``__init__`` method to allow underscores to be used in command
+ names. This optional argument is defaulted to True to maintain
+ current behavior. (contributed by Joe Server)
+- Use flake8_ for style checking.
+- Relax version requirement for PrettyTable dependency to allow point
+ releases of 0.7.
+
+.. _flake8: https://pypi.python.org/pypi/flake8
Documentation
=============
diff --git a/docs/source/history.rst b/docs/source/history.rst
index ff7c455..552ed30 100644
--- a/docs/source/history.rst
+++ b/docs/source/history.rst
@@ -2,13 +2,15 @@
Release History
=================
-dev
+1.3.2
- Add ``convert_underscores`` parameter to ``CommandManager`` ``__init__``
method to allow underscores to be used in command names. This optional
argument is defaulted to True to maintain current behavior.
(contributed by Joe Server)
- Use flake8_ for style checking.
+ - Relax version requirement for PrettyTable dependency to allow
+ point releases of 0.7.
.. _flake8: https://pypi.python.org/pypi/flake8
diff --git a/setup.py b/setup.py
index bfbfeaa..c126dcd 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
PROJECT = 'cliff'
# Change docs/source/conf.py too!
-VERSION = '1.3.1'
+VERSION = '1.3.2'
# Bootstrap installation of Distribute
import distribute_setup