summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--announce.rst13
-rw-r--r--docs/source/history.rst1
-rw-r--r--setup.py2
3 files changed, 10 insertions, 6 deletions
diff --git a/announce.rst b/announce.rst
index 4f068c4..e002189 100644
--- a/announce.rst
+++ b/announce.rst
@@ -1,6 +1,6 @@
-========================================================================
- cliff -- Command Line Interface Formulation Framework -- version 1.2.1
-========================================================================
+======================================================================
+ cliff -- Command Line Interface Formulation Framework -- version 1.3
+======================================================================
.. tags:: python cliff release DreamHost
@@ -11,8 +11,11 @@ other extensions.
What's New In This Release?
===========================
-- Fix problem with documentation packaging.
-- Fix problem with missing ``izip`` import in ``lister.py``.
+- Allow user to pass ``argparse_kwargs`` argument to the
+ ``build_option_parser`` method. This argument can contain extra
+ keyword arguments which are passed to the ``ArgumentParser`` constructor.
+ (contributed by Tomaz Muraus)
+- Document the dependency on using distribute.
Documentation
=============
diff --git a/docs/source/history.rst b/docs/source/history.rst
index 586e374..c7c3c11 100644
--- a/docs/source/history.rst
+++ b/docs/source/history.rst
@@ -8,6 +8,7 @@
``build_option_parser`` method. This argument can contain extra
keyword arguments which are passed to the ``ArgumentParser`` constructor.
(contributed by Tomaz Muraus)
+ - Updated documentation to include dependency on distribute.
1.2.1
diff --git a/setup.py b/setup.py
index f3034dc..3b5e49b 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
PROJECT = 'cliff'
# Change docs/source/conf.py too!
-VERSION = '1.2.1'
+VERSION = '1.3'
# Bootstrap installation of Distribute
import distribute_setup