summaryrefslogtreecommitdiff
path: root/INSTALL.txt
diff options
context:
space:
mode:
authorZearin <zearin@gonk.net>2011-10-05 17:05:31 -0400
committerZearin <zearin@gonk.net>2011-10-05 17:05:31 -0400
commitaa19e3b9c9f03f7320c2d5470fa977ed0bbdeeab (patch)
tree97d86fe3a03114be08aac12a7097aa80ac03bc2a /INSTALL.txt
downloadcmd2-aa19e3b9c9f03f7320c2d5470fa977ed0bbdeeab.tar.gz
Initial import.
Copy of the Python module cmd2 by Catherine Devlin. Note that this is NOT the official copy (it’s at http://www.assembla.com/spaces/python-cmd2/wiki ). I’d rather just work using git + GitHub instead of hg + Assembla. ☺ OTOH, I fully intend to submit changes back to the official repo on Assembla—so don’t be shy, fork away. I’m happy for any help!
Diffstat (limited to 'INSTALL.txt')
-rw-r--r--INSTALL.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/INSTALL.txt b/INSTALL.txt
new file mode 100644
index 0000000..76e138e
--- /dev/null
+++ b/INSTALL.txt
@@ -0,0 +1,23 @@
+cmd2 can be installed from PyPI by ``easy_install`` or ``pip``.
+
+Development trunk can be downloaded with mercurial::
+
+ hg clone http://hg.assembla.com/python-cmd2
+
+To install from the trunk, ``cd python-cmd2`` and run ``python setup.py install`` or ``python setup.py develop`` (requires setuptools). (Use ``root`` account, or ``sudo``, on *nix.)
+
+Python 3
+--------
+
+The Python 3 egg downloaded from PyPI or installed by ``pip`` or ``easy_install`` is ready to go.
+
+To install from source for Python 3, the 2to3 transformations must be applied to ``cmd2.py``.
+The best way to do this is to install ``distribute`` on Python 3 before installing
+``cmd1``::
+
+ curl -O http://python-distribute.org/distribute_setup.py
+ sudo python3 distribute_setup.py
+
+ sudo python3 setup.py install
+
+2to3 won't run if there's a ``build`` directory that's newer than your source code. Deleting the ``cmd2/build`` directory before running setup.py ensures that this won't be a problem.