summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml82
1 files changed, 76 insertions, 6 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 3c3135b..1dc3927 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "python-creole"
-version = "1.4.10"
+version = "1.5.0.rc0"
description = "python-creole is an open-source (GPL) markup converter in pure Python for: creole2html, html2creole, html2ReSt, html2textile"
# Will be generated from README.creole with: "poetry run update_rst_readme"
@@ -17,10 +17,10 @@ classifiers = [
"Intended Audience :: Developers",
"License :: OSI Approved :: GNU General Public License (GPL)",
"Programming Language :: Python",
- "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
"Programming Language :: Python :: Implementation :: PyPy",
"Operating System :: OS Independent",
"Topic :: Documentation",
@@ -36,7 +36,7 @@ packages = [
include = ['AUTHORS', 'LICENSE']
[tool.poetry.dependencies]
-python = ">=3.6,<4.0.0"
+python = ">=3.7,<4.0.0"
docutils = "*"
[tool.poetry.dev-dependencies]
@@ -48,10 +48,9 @@ textile = "*"
pytest = "*"
pytest-cov = "*"
isort = "*"
-flake8 = "*"
-flynt = "*"
+pylint = "*"
autopep8 = "*"
-pyupgrade = "*"
+darker = "*"
[tool.poetry.scripts]
creole2html = "creole.cmdline:cli_creole2html"
@@ -65,3 +64,74 @@ publish = "creole.publish:publish"
requires = ["poetry>=0.12"]
build-backend = "poetry.masonry.api"
+
+[tool.darker]
+src = ['.']
+revision = "origin/main..."
+line_length = 100
+verbose = true
+skip_string_normalization = true
+diff = false
+check = false
+stdout = false
+isort = true
+lint = [
+ "pylint",
+]
+log_level = "INFO"
+
+
+[tool.flynt]
+line_length = 100
+
+
+[tool.isort]
+# https://pycqa.github.io/isort/docs/configuration/config_files/#pyprojecttoml-preferred-format
+atomic=true
+profile='black'
+line_length=100
+skip_glob=["*/htmlcov/*"]
+known_first_party=["creole"]
+lines_after_imports=2
+
+
+[tool.pytest.ini_options]
+# https://docs.pytest.org/en/latest/customize.html#pyproject-toml
+minversion = "6.0"
+norecursedirs = ".* __pycache__ conf coverage* dist htmlcov"
+# sometimes helpfull "addopts" arguments:
+# -vv
+# --verbose
+# --capture=no
+# --trace-config
+# --full-trace
+# -p no:warnings
+addopts = """
+ --cov=.
+ --cov-report term-missing
+ --cov-report html
+ --cov-report xml
+ --no-cov-on-fail
+ --showlocals
+ --doctest-modules
+ --failed-first
+ --last-failed-no-failures all
+ --new-first
+"""
+# TODO: --mypy
+
+
+[tool.tox]
+# https://tox.readthedocs.io/en/latest/example/basic.html#pyproject-toml-tox-legacy-ini
+legacy_tox_ini = """
+[tox]
+isolated_build = True
+envlist = py310,py39,py38,py37
+skip_missing_interpreters = True
+
+[testenv]
+passenv = *
+whitelist_externals = make
+commands =
+ make pytest
+"""