summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorniemeyer <>2007-11-12 14:06:05 +0000
committerniemeyer <>2007-11-12 14:06:05 +0000
commit313ef14315e162119aeb9b0ee30d8d468cd23733 (patch)
treeab23d9d8f73c4d5399541609cfc240c43dc79848 /setup.py
parentc52a13d7d3057f33b98d25db7be14cefef88393f (diff)
downloaddateutil-313ef14315e162119aeb9b0ee30d8d468cd23733.tar.gz
Moving the version number to dateutil/__init__.py, as requested
by Darren Dale.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0f76991..d852379 100644
--- a/setup.py
+++ b/setup.py
@@ -4,16 +4,23 @@ from distutils.core import setup
from os.path import isfile, join
import glob
import os
+import re
+
if isfile("MANIFEST"):
os.unlink("MANIFEST")
+
# Get PYTHONLIB with no prefix so --prefix installs work.
PYTHONLIB = join(get_python_lib(standard_lib=1, prefix=''), 'site-packages')
ZONEINFO = join("dateutil", "zoneinfo")
+VERSION = re.search('__version__ = "([^"]+)"',
+ open("dateutil/__init__.py").read()).group(1)
+
+
setup(name="python-dateutil",
- version = "1.2",
+ version = VERSION,
description = "Extensions to the standard python 2.3+ datetime module",
author = "Gustavo Niemeyer",
author_email = "gustavo@niemeyer.net",