summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorniemeyer <>2005-02-23 18:33:30 +0000
committerniemeyer <>2005-02-23 18:33:30 +0000
commitdebf3cd82a0aa85949c84eefa13eab5fd5be3949 (patch)
treedc73cefb189c3bb02209ded216fdd74405142f72 /setup.py
parentf57df0b03af23f5459cb6bc04fdc4a02e58eac50 (diff)
downloaddateutil-debf3cd82a0aa85949c84eefa13eab5fd5be3949.tar.gz
- Now tzfile() will unpickle to the updated file.
- Adding tzwin.py, contributed by Jeffrey Harris. - Minor tweaks in setup.py. - Adding README and example.py. - Putting old scheduler.py in the sandbox.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index bcf8029..d8067e9 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,13 @@
#!/usr/bin/python
+from distutils.sysconfig import get_python_lib
from distutils.core import setup
+import glob
+import os
+
+if os.path.isfile("MANIFEST"):
+ os.unlink("MANIFEST")
+
+PYTHONLIB = get_python_lib(1)
setup(name="python-dateutil",
version = "0.5",
@@ -14,4 +22,6 @@ The dateutil module provides powerful extensions to the standard
datetime module, available in Python 2.3+.
""",
packages = ["dateutil"],
+ data_files = [(PYTHONLIB+"/dateutil/zoneinfo",
+ glob.glob("dateutil/zoneinfo/zoneinfo*.tar.*"))],
)