summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2019-04-14 10:55:22 +0200
committerChristian Heimes <christian@python.org>2019-04-14 11:45:26 +0200
commit44586bdd49b04e0b600321e66db135ca1d0a914e (patch)
tree3aff2f58f61dd03b72b4ed41b381278681c7e5e1
parent0aa6977e37d343c1698e203d54fd2d4d31368f6b (diff)
downloaddefusedxml-git-44586bdd49b04e0b600321e66db135ca1d0a914e.tar.gz
Drop support for Python 3.4
Signed-off-by: Christian Heimes <christian@python.org>
-rw-r--r--.travis.yml2
-rw-r--r--CHANGES.txt1
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
4 files changed, 3 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 9883480..682c6e4 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -8,8 +8,6 @@ matrix:
include:
- python: 2.7
env: TOXENV=py27
- - python: 3.4
- env: TOXENV=py34
- python: 3.5
env: TOXENV=py35
- python: 3.6
diff --git a/CHANGES.txt b/CHANGES.txt
index 53977c5..8d6225c 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -7,6 +7,7 @@ defusedxml 0.6.0.dev1
*Release date: ??-???-2019*
- Test on Python 3.7 stable and 3.8-dev
+- Drop support for Python 3.4
defusedxml 0.5.0
diff --git a/setup.py b/setup.py
index 0ad28e4..3b4e4e2 100644
--- a/setup.py
+++ b/setup.py
@@ -55,11 +55,11 @@ setup(
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Topic :: Text Processing :: Markup :: XML",
],
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*",
)
diff --git a/tox.ini b/tox.ini
index 8714a2c..e665374 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,py34,py35,py36,py37,py38,pep8py2,pep8py3,doc
+envlist = py27,py35,py36,py37,py38,pep8py2,pep8py3,doc
skip_missing_interpreters = true
[testenv]