summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
author?ric Araujo <merwok@netwok.org>2011-11-25 12:42:35 +0100
committer?ric Araujo <merwok@netwok.org>2011-11-25 12:42:35 +0100
commit0d229fdc696a1eff38737fc0036e0d5d8b8447af (patch)
treedb0a597392660f2c48086fc677d179ee00777c9b /setup.py
parentaeefa8b74658a44d5d9c7053d7f1355b13b7e3a8 (diff)
downloaddisutils2-0d229fdc696a1eff38737fc0036e0d5d8b8447af.tar.gz
Kludge for hashlib
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 7 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index caf49ee..d42bdd2 100644
--- a/setup.py
+++ b/setup.py
@@ -194,8 +194,13 @@ def prepare_hashlib_extensions():
sources=['distutils2/_backport/md5module.c',
'distutils2/_backport/md5.c'],
depends=['distutils2/_backport/md5.h']) )
- if openssl_ver < 0x908000:
- # OpenSSL doesn't do these until 0.9.8 so we'll bring our own
+ # XXX always compile sha256 and sha512 to have a working hashlib (maybe
+ # I (merwok) can't compile _ssl and thus _hashlib for 2.4, maybe because of
+ # Debian multiarch, even though I set all needed build vars (and can
+ # compile _ssl for 2.6 for example)
+ if True:
+ #if openssl_ver < 0x908000:
+ # # OpenSSL doesn't do these until 0.9.8 so we'll bring our own
exts.append(Extension('distutils2._backport._sha256',
['distutils2/_backport/sha256module.c']))
exts.append(Extension('distutils2._backport._sha512',