summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorMalcolm Tredinnick <malcolm.tredinnick@gmail.com>2007-04-03 12:28:19 +0000
committerMalcolm Tredinnick <malcolm.tredinnick@gmail.com>2007-04-03 12:28:19 +0000
commitb9d077c10d0ded84ee91ac375eafb24e1658237d (patch)
treede2ab952ebf32d84726ab3f5bf8e0b37e29d6132 /scripts
parentabe6c5d6ae20a3fd29e30ca73df3a54c8177a69c (diff)
downloaddjango-b9d077c10d0ded84ee91ac375eafb24e1658237d.tar.gz
Fixed #3338, #3536, #3796 -- Fixed a bunch of setup and build problems in a
portable fashion. That took a *lot* longer to debug than I thought it would, so let's try not to break it. git-svn-id: http://code.djangoproject.com/svn/django/trunk@4912 bcc190cf-cafb-0310-a4f2-bffc1f526a37
Diffstat (limited to 'scripts')
-rw-r--r--scripts/rpm-install.sh12
1 files changed, 8 insertions, 4 deletions
diff --git a/scripts/rpm-install.sh b/scripts/rpm-install.sh
index 07a087c447..d3d95bcdb1 100644
--- a/scripts/rpm-install.sh
+++ b/scripts/rpm-install.sh
@@ -1,12 +1,14 @@
#! /bin/sh
#
-# this file is *inserted* into the install section of the generated
-# spec file
+# This file becomes the install section of the generated spec file.
#
-# this is, what dist.py normally does
+# This is what dist.py normally does.
python setup.py install --root=${RPM_BUILD_ROOT} --record="INSTALLED_FILES"
+# Sort the filelist so that directories appear before files. This avoids
+# duplicate filename problems on some systems.
+touch DIRS
for i in `cat INSTALLED_FILES`; do
if [ -f ${RPM_BUILD_ROOT}/$i ]; then
echo $i >>FILES
@@ -16,4 +18,6 @@ for i in `cat INSTALLED_FILES`; do
fi
done
-cat DIRS FILES >INSTALLED_FILES
+# Make sure we match foo.pyo and foo.pyc along with foo.py (but only once each)
+sed -e "/\.py[co]$/d" -e "s/\.py$/.py*/" DIRS FILES >INSTALLED_FILES
+