summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Halley <halley@play-bow.org>2020-07-01 10:15:19 -0700
committerBob Halley <halley@play-bow.org>2020-07-01 10:15:19 -0700
commit5765181c220b96b1543395faaf5e43eb778a45ff (patch)
treefa70715e46d4f7fc50b82d7fc8207a1190e7c777
parent407397f8d0143592620d1171ac503c07f9dcf537 (diff)
downloaddnspython-5765181c220b96b1543395faaf5e43eb778a45ff.tar.gz
try to deconfuse codecov
-rw-r--r--.travis.yml2
-rw-r--r--azure-pipelines.yml2
-rw-r--r--codecov.yml5
3 files changed, 7 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 2d416a5..584f4a7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -10,6 +10,6 @@ install:
- curl -sSL https://raw.githubusercontent.com/python-poetry/poetry/master/get-poetry.py | python
- ~/.poetry/bin/poetry install -E dnssec -E doh -E idna -E trio -E curio
script:
- - ~/.poetry/bin/poetry run pytest --cov=dns --cov-report=xml:coverage.xml
+ - ~/.poetry/bin/poetry run pytest --cov=. --cov-report=xml:coverage.xml
after_success:
- bash <(curl -s https://codecov.io/bash)
diff --git a/azure-pipelines.yml b/azure-pipelines.yml
index 0f79715..5185c7c 100644
--- a/azure-pipelines.yml
+++ b/azure-pipelines.yml
@@ -31,7 +31,7 @@ jobs:
- script: |
pip install pytest pytest-cov pytest-azurepipelines
- pytest --junitxml=junit/test-results.xml --cov=dns --cov-report=xml --cov-report=html
+ pytest --junitxml=junit/test-results.xml --cov=. --cov-report=xml --cov-report=html
displayName: 'pytest'
- task: PublishTestResults@2
diff --git a/codecov.yml b/codecov.yml
index 1b44632..002b105 100644
--- a/codecov.yml
+++ b/codecov.yml
@@ -4,3 +4,8 @@ coverage:
default:
target: auto
threshold: 2%
+ignore:
+ - 'tests/*'
+ - 'examples/*'
+ - 'doc/*'
+ - 'setup.py'