summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2020-05-01 08:32:57 -0700
committerBob Halley <halley@dnspython.org>2020-05-01 08:32:57 -0700
commit035598d16b21c5716b55ceb2583437219298ebbc (patch)
tree35eec32ac97ca5e8d6e56b95724c35074a583ee7 /Makefile
parent1aebd5b2f0e2145ec2ee33f3996b0175ce24f025 (diff)
downloaddnspython-035598d16b21c5716b55ceb2583437219298ebbc.tar.gz
start poetry and pyenv support
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index d0993e0..d3550cd 100644
--- a/Makefile
+++ b/Makefile
@@ -18,9 +18,6 @@
# $Id: Makefile,v 1.16 2004/03/19 00:17:27 halley Exp $
PYTHON=python
-PIP=pip
-# set this to "--user" if you prefer
-PIPMODE=
all:
${PYTHON} ./setup.py build
@@ -72,5 +69,10 @@ lint:
lint3: lint
typecheck:
- ${PIP} show mypy >/dev/null 2>&1 || ${PIP} install ${PIPMODE} mypy
- mypy examples tests
+ mypy examples tests dns
+
+potest:
+ poetry run python -m tests.utest
+
+potype:
+ poetry run python -m mypy examples tests dns/*.py