summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2018-12-09 12:06:24 -0800
committerBob Halley <halley@dnspython.org>2018-12-09 12:06:24 -0800
commit129f9e79ff508e36bac08fd588769525d9214a57 (patch)
tree8d5c0dc44ef1e232d1e87e38f1c777aba74c81ff /Makefile
parenta0a975bc26728996313425ad4ba8b1281849153c (diff)
downloaddnspython-129f9e79ff508e36bac08fd588769525d9214a57.tar.gz
Remove _compat module.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 958e684..d20eed2 100644
--- a/Makefile
+++ b/Makefile
@@ -60,19 +60,14 @@ tags:
check: test
test:
- cd tests; make PYTHON=${PYTHON} test
-
-test2:
- cd tests; make PYTHON=python test
-
-test3:
cd tests; make PYTHON=${PYTHON3} test
-lint:
- pylint dns tests examples/*.py
+test3: test
-lint3:
+lint:
pylint3 dns tests examples/*.py
+lint3: lint
+
typecheck:
if [ $(shell python -c "import sys; print(sys.version_info[0])") -ne 2 ]; then pip install mypy; mypy examples tests; else echo Skipping typecheck on Python 2; fi