summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2022-02-25 13:29:09 -0800
committerBob Halley <halley@dnspython.org>2022-03-05 12:39:50 -0800
commit392ac9bd4bfceffe33563409eb3a02615e729188 (patch)
treeefdc764885988ec06a6c9bf6f6e5765a96a4940b /Makefile
parent95045c5834732042b59f3fcc08f086e7cf139b22 (diff)
downloaddnspython-392ac9bd4bfceffe33563409eb3a02615e729188.tar.gz
Add integrated typing to much of dnspython.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 76e7028..fe4e8bd 100644
--- a/Makefile
+++ b/Makefile
@@ -56,7 +56,10 @@ potestlf:
poetry run pytest --lf
potype:
- poetry run python -m mypy examples tests dns/*.py
+ poetry run python -m mypy dns/*.py
+
+potypetests:
+ poetry run python -m mypy --check-untyped-defs examples tests
polint:
poetry run pylint dns