summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJanus <ysangkok@gmail.com>2018-07-23 16:11:00 +0200
committerJanus <ysangkok@gmail.com>2018-07-31 20:10:52 +0200
commit5c5de7bb1ad26d6d6bb82ed2deb64748b46ac599 (patch)
treee4510f90a598e484e57314dc04217259ef34a690 /Makefile
parent2e6e81852b63eb64b68a08a27cc6e440819b6b58 (diff)
downloaddnspython-5c5de7bb1ad26d6d6bb82ed2deb64748b46ac599.tar.gz
Initial type signatures
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index ca37045..ce3e716 100644
--- a/Makefile
+++ b/Makefile
@@ -70,3 +70,6 @@ lint:
lint3:
pylint3 dns tests examples/*.py
+
+typecheck:
+ if [ $(shell python -c "import sys; print(sys.version_info[0])") -ne 2 ]; then pip install mypy; mypy examples tests; else echo Skipping typecheck on Python 2; fi