summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2022-03-25 12:16:21 -0700
committerBob Halley <halley@dnspython.org>2022-03-25 12:16:21 -0700
commit759421d3e9add44fb5aecf3bac2939ef6bc85b59 (patch)
treedec422bc2f75968219f43210214a6530428227fe /Makefile
parentb625c08b178af27030b55180754e7e120501ada6 (diff)
downloaddnspython-759421d3e9add44fb5aecf3bac2939ef6bc85b59.tar.gz
always install types if needed when running mypy
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f5e5438..bbf1b50 100644
--- a/Makefile
+++ b/Makefile
@@ -56,7 +56,7 @@ potestlf:
poetry run pytest --lf
potype:
- poetry run python -m mypy --disallow-incomplete-defs dns
+ poetry run python -m mypy --install-types --non-interactive --disallow-incomplete-defs dns
potypetests:
poetry run python -m mypy --check-untyped-defs examples tests