summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2016-10-08 16:36:58 -0700
committerBob Halley <halley@dnspython.org>2016-10-08 16:36:58 -0700
commit9cd285f1b53e2dbe9f699b0f8696cd61725e245d (patch)
treeeccd3b5a26c5707a01a0f3bd5b20cf036864e5d0 /Makefile
parent28c99cc66448b0df8ba2c9e959f46217c912e57e (diff)
downloaddnspython-9cd285f1b53e2dbe9f699b0f8696cd61725e245d.tar.gz
make python 3 default for kitting
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index cb96959..845abd3 100644
--- a/Makefile
+++ b/Makefile
@@ -16,6 +16,7 @@
# $Id: Makefile,v 1.16 2004/03/19 00:17:27 halley Exp $
PYTHON=python
+PYTHON3=python3
all:
${PYTHON} ./setup.py build
@@ -48,9 +49,7 @@ docclean:
rm -rf html.tar.gz html.zip html
kits:
- ${PYTHON} ./setup.py sdist --formats=gztar,zip
-# ${PYTHON} ./setup.py bdist_wininst
-# ${PYTHON} ./setup.py bdist_rpm
+ ${PYTHON3} ./setup.py sdist --formats=gztar,zip bdist_wheel
tags:
find . -name '*.py' -print | etags -
@@ -64,7 +63,7 @@ test2:
cd tests; make PYTHON=python test
test3:
- cd tests; make PYTHON=python3 test
+ cd tests; make PYTHON=${PYTHON3} test
lint:
pylint dns tests examples/*.py