summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBob Halley <halley@play-bow.org>2020-06-28 18:16:52 -0700
committerBob Halley <halley@play-bow.org>2020-06-28 18:16:52 -0700
commitd90b32a5d1f75af87f107f663d2afcef95eab6d1 (patch)
treef5c20eb2bf8158d176e4209373a1993364ffe703 /Makefile
parent5317fc7b9d9062bffc19ee99c586c8bf34ef214c (diff)
downloaddnspython-d90b32a5d1f75af87f107f663d2afcef95eab6d1.tar.gz
cleanup Makefile; add potestlf rule
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile37
1 files changed, 9 insertions, 28 deletions
diff --git a/Makefile b/Makefile
index 17110c6..b610657 100644
--- a/Makefile
+++ b/Makefile
@@ -30,50 +30,31 @@ clean:
find . -name '*.pyc' -exec rm {} \;
find . -name '*.pyo' -exec rm {} \;
rm -f TAGS
+ rm -rf htmlcov .coverage
+ rm -rf .pytest_cache
distclean: clean docclean
rm -rf build dist
rm -f MANIFEST
+ rm -rf dnspython.egg-info
-doco:
- epydoc -v -n dnspython -u http://www.dnspython.org \
- dns/*.py dns/rdtypes/*.py dns/rdtypes/ANY/*.py \
- dns/rdtypes/CH/*.py \
- dns/rdtypes/IN/*.py
-
-dockits: doco
- mv html dnspython-html
- tar czf html.tar.gz dnspython-html
- zip -r html.zip dnspython-html
- mv dnspython-html html
+doc:
+ cd doc; make html
docclean:
- rm -rf html.tar.gz html.zip html
-
-kits:
- ${PYTHON} ./setup.py sdist --formats=gztar,zip bdist_wheel
-
-tags:
- find . -name '*.py' -print | etags -
+ rm -rf doc/_build
check: test
test:
cd tests; make test
-test3: test
-
-lint:
- pylint dns tests examples/*.py
-
-lint3: lint
-
-typecheck:
- mypy examples tests dns
-
potest:
poetry run pytest
+potestlf:
+ poetry run pytest --lf
+
potype:
poetry run python -m mypy examples tests dns/*.py