summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2018-12-09 15:02:00 -0800
committerBob Halley <halley@dnspython.org>2018-12-09 15:02:00 -0800
commitda0a2157ddeaece28d339e822aa4cef62e44bc88 (patch)
tree8a13ce2531ef6d12e770542ce18b231035c5f665 /Makefile
parent7a0d63e4a7f6bff0259a5f23a0241e7a39d7d68a (diff)
downloaddnspython-da0a2157ddeaece28d339e822aa4cef62e44bc88.tar.gz
more python 3 only cleanups
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index e6a930c..d0993e0 100644
--- a/Makefile
+++ b/Makefile
@@ -18,7 +18,9 @@
# $Id: Makefile,v 1.16 2004/03/19 00:17:27 halley Exp $
PYTHON=python
-PYTHON3=python3
+PIP=pip
+# set this to "--user" if you prefer
+PIPMODE=
all:
${PYTHON} ./setup.py build
@@ -52,7 +54,7 @@ docclean:
rm -rf html.tar.gz html.zip html
kits:
- ${PYTHON3} ./setup.py sdist --formats=gztar,zip bdist_wheel
+ ${PYTHON} ./setup.py sdist --formats=gztar,zip bdist_wheel
tags:
find . -name '*.py' -print | etags -
@@ -60,7 +62,7 @@ tags:
check: test
test:
- cd tests; make PYTHON=${PYTHON3} test
+ cd tests; make test
test3: test
@@ -70,4 +72,5 @@ lint:
lint3: lint
typecheck:
- if [ $(shell python -c "import sys; print(sys.version_info[0])") -ne 2 ]; then pip install mypy; mypy examples tests; else echo Skipping typecheck on Python 2; fi
+ ${PIP} show mypy >/dev/null 2>&1 || ${PIP} install ${PIPMODE} mypy
+ mypy examples tests