summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormilde <milde@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2022-12-01 21:13:16 +0000
committermilde <milde@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2022-12-01 21:13:16 +0000
commit2cc73e924e5f7dae6a01722851eef37f81cc0139 (patch)
treed4ead5947750a857d827d5994f393527e79a66f1
parent025f0386291c78dd098e2ab0840b1ecdce6015fa (diff)
downloaddocutils-2cc73e924e5f7dae6a01722851eef37f81cc0139.tar.gz
Raise version to 0.20b.dev.
There are not only bugfix changes since 0.19, so a new "minor" release is required. git-svn-id: https://svn.code.sf.net/p/docutils/code/trunk@9291 929543f6-e4f2-0310-98a6-ba3bd3dd1d04
-rw-r--r--docutils/README.txt2
-rw-r--r--docutils/docs/dev/release.txt38
-rw-r--r--docutils/docutils/__init__.py6
-rw-r--r--docutils/test/functional/expected/compact_lists.html2
-rw-r--r--docutils/test/functional/expected/dangerous.html2
-rw-r--r--docutils/test/functional/expected/embed_images_html5.html2
-rw-r--r--docutils/test/functional/expected/field_name_limit.html2
-rw-r--r--docutils/test/functional/expected/footnotes_html5.html2
-rw-r--r--docutils/test/functional/expected/math_output_html.html2
-rw-r--r--docutils/test/functional/expected/math_output_latex.html2
-rw-r--r--docutils/test/functional/expected/math_output_mathjax.html2
-rw-r--r--docutils/test/functional/expected/math_output_mathml.html2
-rw-r--r--docutils/test/functional/expected/misc_rst_html4css1.html2
-rw-r--r--docutils/test/functional/expected/misc_rst_html5.html2
-rw-r--r--docutils/test/functional/expected/pep_html.html2
-rw-r--r--docutils/test/functional/expected/rst_html5_tuftig.html2
-rw-r--r--docutils/test/functional/expected/standalone_rst_docutils_xml.xml2
-rw-r--r--docutils/test/functional/expected/standalone_rst_html4css1.html2
-rw-r--r--docutils/test/functional/expected/standalone_rst_html5.html2
-rw-r--r--docutils/test/functional/expected/standalone_rst_s5_html_1.html2
-rw-r--r--docutils/test/functional/expected/standalone_rst_s5_html_2.html2
-rw-r--r--docutils/test/test__init__.py2
-rwxr-xr-xsandbox/infrastructure/set_version.sh2
-rwxr-xr-xsandbox/infrastructure/version_identifier_parsing.py2
24 files changed, 46 insertions, 42 deletions
diff --git a/docutils/README.txt b/docutils/README.txt
index 38c5262f3..0049339f8 100644
--- a/docutils/README.txt
+++ b/docutils/README.txt
@@ -1,7 +1,7 @@
.. include:: docs/header0.txt
==============================
- README: Docutils 0.19.1b.dev
+ README: Docutils 0.20b.dev
==============================
:Author: David Goodger
diff --git a/docutils/docs/dev/release.txt b/docutils/docs/dev/release.txt
index 7c8daf438..7ad1fde92 100644
--- a/docutils/docs/dev/release.txt
+++ b/docutils/docs/dev/release.txt
@@ -25,11 +25,14 @@ Releasing (post 2020)
* Change HISTORY.txt title ``Changes Since <previous release>`` to ``Release <version>``.
-* Set new version with ``sandbox/infrastructure/set_version.sh <version>``
+* Set new version (replace ``<version>`` with the new version indentifier
+ and ``<docutils-repository-root>`` with the dir containing
+ ``HISTORY.txt`` and ``RELEASE-NOTES.txt``)::
- Check what was changed with version control system by ``set_version.sh``
+ cd <docutils-repository-root>
+ ../sandbox/infrastructure/set_version.sh <version>
- Change docutils/__init__.py __version_info__ tuple.
+ Check what was changed by ``set_version.sh``.
Run tests ::
@@ -37,7 +40,8 @@ Releasing (post 2020)
python3 test/alltests.py
or use tox.
-
+ In case of errors, clearing ``docutils/__pycache__`` may help.
+
``export PYTHONWARNINGS=default`` prints DeprecationWarnings in python3.
* Generate wheel and source-distribution::
@@ -64,13 +68,13 @@ Releasing (post 2020)
* Commit changes ... the changed version number.
-* tag 0.## (Note: only directory docutils is copied)::
+* tag #.# (Note: only directory docutils is copied)::
svn copy svn+ssh://grubert@svn.code.sf.net/p/docutils/code/trunk/docutils \
- svn+ssh://grubert@svn.code.sf.net/p/docutils/code/tags/docutils-0.## \
- -m "tagging release 0.##"
+ svn+ssh://grubert@svn.code.sf.net/p/docutils/code/tags/docutils-#.# \
+ -m "tagging release #.#"
-* Update your source directory.
+* Update your source directory.
* Rebuild wheel and source-distribution ::
python3 setup.py sdist
@@ -78,7 +82,7 @@ Releasing (post 2020)
* Now upload to pypi::
- python3 -m twine upload dist/docutils-0.##*
+ python3 -m twine upload dist/docutils-#.#*
* Remove previous package from local cache::
@@ -97,28 +101,28 @@ Releasing (post 2020)
* Notify to docutils-developer and user.
-* upload source and generated html to sf-htdocs/0.## ::
+* upload source and generated html to sf-htdocs/#.# ::
mkdir tmp1
cd tmp1
- tar xzvf ../dist/docutils-0.##.tar.gz
- cd docutils-0.##/
+ tar xzvf ../dist/docutils-#.#.tar.gz
+ cd docutils-#.#/
tools/buildhtml.py .
find . -name \*.pyc -exec rm -v {} \;
find . -name __pycache__ -exec rmdir -v {} \;
rm -r docutils.egg-info
- rsync -e ssh -r -t ./ web.sourceforge.net:/home/project-web/docutils/htdocs/0.##
+ rsync -e ssh -r -t ./ web.sourceforge.net:/home/project-web/docutils/htdocs/#.#
* Check web/index.txt for necessary corrections.
* Run sandbox/infrastructure/docutils-update.local to update web-content.
* Release to sourceforge.
- - Upload tar.gz and 0.16 release notes to sourceforge.
- - Select docutils-0.16.tar.gz as default for all OS.
+ - Upload docutils-#.#.tar.gz and release notes to sourceforge.
+ - Select docutils-#.#.tar.gz as default for all OS.
-* set_version 0.#.#+1b.dev
+* set_version #.{#+1}b.dev
* test with py3
-* docutils/HISTORY.txt: add title "Changes Since 0.##"
+* docutils/HISTORY.txt: add title "Changes Since #.#"
* run sandbox/infrastructure/docutils-update.local
diff --git a/docutils/docutils/__init__.py b/docutils/docutils/__init__.py
index 3052208e7..e3d21baa3 100644
--- a/docutils/docutils/__init__.py
+++ b/docutils/docutils/__init__.py
@@ -54,7 +54,7 @@ from collections import namedtuple
__docformat__ = 'reStructuredText'
-__version__ = '0.19.1b.dev'
+__version__ = '0.20b.dev'
"""Docutils version identifier (complies with PEP 440)::
major.minor[.micro][releaselevel[serial]][.dev]
@@ -116,8 +116,8 @@ class VersionInfo(namedtuple('VersionInfo',
__version_info__ = VersionInfo(
major=0,
- minor=19,
- micro=1,
+ minor=20,
+ micro=0,
releaselevel='beta', # one of 'alpha', 'beta', 'candidate', 'final'
serial=0, # pre-release number (0 for final releases and snapshots)
release=False # True for official releases and pre-releases
diff --git a/docutils/test/functional/expected/compact_lists.html b/docutils/test/functional/expected/compact_lists.html
index b2ee45a25..edb015e66 100644
--- a/docutils/test/functional/expected/compact_lists.html
+++ b/docutils/test/functional/expected/compact_lists.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<title>compact_lists.txt</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/docutils/test/functional/expected/dangerous.html b/docutils/test/functional/expected/dangerous.html
index 41c108705..26d52c79f 100644
--- a/docutils/test/functional/expected/dangerous.html
+++ b/docutils/test/functional/expected/dangerous.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<title>dangerous.txt</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/docutils/test/functional/expected/embed_images_html5.html b/docutils/test/functional/expected/embed_images_html5.html
index e582eb371..c90e80d87 100644
--- a/docutils/test/functional/expected/embed_images_html5.html
+++ b/docutils/test/functional/expected/embed_images_html5.html
@@ -3,7 +3,7 @@
<head>
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta charset="utf-8"/>
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<title>Embedded Images</title>
<link rel="stylesheet" href="../input/data/minimal.css" type="text/css" />
<link rel="stylesheet" href="../input/data/plain.css" type="text/css" />
diff --git a/docutils/test/functional/expected/field_name_limit.html b/docutils/test/functional/expected/field_name_limit.html
index 019a2c9af..d11cad9c4 100644
--- a/docutils/test/functional/expected/field_name_limit.html
+++ b/docutils/test/functional/expected/field_name_limit.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<title>field_list.txt</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/docutils/test/functional/expected/footnotes_html5.html b/docutils/test/functional/expected/footnotes_html5.html
index 4310f7906..9165364b9 100644
--- a/docutils/test/functional/expected/footnotes_html5.html
+++ b/docutils/test/functional/expected/footnotes_html5.html
@@ -2,7 +2,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta charset="utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Test footnote and citation rendering</title>
<link rel="stylesheet" href="../input/data/minimal.css" type="text/css" />
diff --git a/docutils/test/functional/expected/math_output_html.html b/docutils/test/functional/expected/math_output_html.html
index 29011fbbc..f7c3a81f8 100644
--- a/docutils/test/functional/expected/math_output_html.html
+++ b/docutils/test/functional/expected/math_output_html.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<title>Mathematics</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
<link rel="stylesheet" href="../input/data/math.css" type="text/css" />
diff --git a/docutils/test/functional/expected/math_output_latex.html b/docutils/test/functional/expected/math_output_latex.html
index 7a6b94f27..704bcb049 100644
--- a/docutils/test/functional/expected/math_output_latex.html
+++ b/docutils/test/functional/expected/math_output_latex.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<title>Mathematics</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/docutils/test/functional/expected/math_output_mathjax.html b/docutils/test/functional/expected/math_output_mathjax.html
index a80d610eb..f093889c7 100644
--- a/docutils/test/functional/expected/math_output_mathjax.html
+++ b/docutils/test/functional/expected/math_output_mathjax.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<title>Mathematics</title>
<script type="text/javascript" src="/usr/share/javascript/mathjax/MathJax.js?config=TeX-AMS_CHTML"></script>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
diff --git a/docutils/test/functional/expected/math_output_mathml.html b/docutils/test/functional/expected/math_output_mathml.html
index 46deac3fc..68b9d0e62 100644
--- a/docutils/test/functional/expected/math_output_mathml.html
+++ b/docutils/test/functional/expected/math_output_mathml.html
@@ -2,7 +2,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta charset="utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Mathematics</title>
<link rel="stylesheet" href="../input/data/minimal.css" type="text/css" />
diff --git a/docutils/test/functional/expected/misc_rst_html4css1.html b/docutils/test/functional/expected/misc_rst_html4css1.html
index 9fec8d866..404275050 100644
--- a/docutils/test/functional/expected/misc_rst_html4css1.html
+++ b/docutils/test/functional/expected/misc_rst_html4css1.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<title>Additional tests with html4css1</title>
<link rel="stylesheet" href="foo&amp;bar.css" type="text/css" />
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
diff --git a/docutils/test/functional/expected/misc_rst_html5.html b/docutils/test/functional/expected/misc_rst_html5.html
index 8b48117d2..52fb991d1 100644
--- a/docutils/test/functional/expected/misc_rst_html5.html
+++ b/docutils/test/functional/expected/misc_rst_html5.html
@@ -2,7 +2,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta charset="utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Additional tests with HTML 5</title>
<link rel="stylesheet" href="../input/data/minimal.css" type="text/css" />
diff --git a/docutils/test/functional/expected/pep_html.html b/docutils/test/functional/expected/pep_html.html
index bf3b009cf..5a0b52191 100644
--- a/docutils/test/functional/expected/pep_html.html
+++ b/docutils/test/functional/expected/pep_html.html
@@ -8,7 +8,7 @@ to templates. DO NOT USE THIS HTML FILE AS YOUR TEMPLATE!
-->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
- <meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+ <meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<title>PEP 100 - Test PEP</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/docutils/test/functional/expected/rst_html5_tuftig.html b/docutils/test/functional/expected/rst_html5_tuftig.html
index ab0531b37..ff609da1b 100644
--- a/docutils/test/functional/expected/rst_html5_tuftig.html
+++ b/docutils/test/functional/expected/rst_html5_tuftig.html
@@ -2,7 +2,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta charset="utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Special Features of the tuftig.css Stylesheet</title>
<link rel="stylesheet" href="../input/data/minimal.css" type="text/css" />
diff --git a/docutils/test/functional/expected/standalone_rst_docutils_xml.xml b/docutils/test/functional/expected/standalone_rst_docutils_xml.xml
index 400a10cdc..7c3fd2101 100644
--- a/docutils/test/functional/expected/standalone_rst_docutils_xml.xml
+++ b/docutils/test/functional/expected/standalone_rst_docutils_xml.xml
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE document PUBLIC "+//IDN docutils.sourceforge.net//DTD Docutils Generic//EN//XML" "http://docutils.sourceforge.net/docs/ref/docutils.dtd">
-<!-- Generated by Docutils 0.19.1b.dev -->
+<!-- Generated by Docutils 0.20b.dev -->
<document ids="restructuredtext-test-document doctitle" names="restructuredtext\ test\ document doctitle" source="functional/input/standalone_rst_docutils_xml.txt" title="reStructuredText Test Document">
<title>reStructuredText Test Document</title>
<subtitle ids="examples-of-syntax-constructs subtitle" names="examples\ of\ syntax\ constructs subtitle">Examples of Syntax Constructs</subtitle>
diff --git a/docutils/test/functional/expected/standalone_rst_html4css1.html b/docutils/test/functional/expected/standalone_rst_html4css1.html
index be0d61105..b9c7e945d 100644
--- a/docutils/test/functional/expected/standalone_rst_html4css1.html
+++ b/docutils/test/functional/expected/standalone_rst_html4css1.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<meta content="reStructuredText, test, parser" name="keywords" />
<meta content="A test document, containing at least one example of each reStructuredText construct." lang="en" name="description" />
<meta name="author" content="David Goodger" />
diff --git a/docutils/test/functional/expected/standalone_rst_html5.html b/docutils/test/functional/expected/standalone_rst_html5.html
index 9b03ecf30..7495303e5 100644
--- a/docutils/test/functional/expected/standalone_rst_html5.html
+++ b/docutils/test/functional/expected/standalone_rst_html5.html
@@ -2,7 +2,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta charset="utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta content="reStructuredText, test, parser" name="keywords" />
<meta content="A test document, containing at least one example of each reStructuredText construct." lang="en" name="description" xml:lang="en" />
diff --git a/docutils/test/functional/expected/standalone_rst_s5_html_1.html b/docutils/test/functional/expected/standalone_rst_s5_html_1.html
index d46d5115b..41f372277 100644
--- a/docutils/test/functional/expected/standalone_rst_s5_html_1.html
+++ b/docutils/test/functional/expected/standalone_rst_s5_html_1.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<meta name="version" content="S5 1.1" />
<meta name="author" content="David Goodger" />
<meta name="date" content="2005-11-28" />
diff --git a/docutils/test/functional/expected/standalone_rst_s5_html_2.html b/docutils/test/functional/expected/standalone_rst_s5_html_2.html
index 78afd07cc..c58334eaf 100644
--- a/docutils/test/functional/expected/standalone_rst_s5_html_2.html
+++ b/docutils/test/functional/expected/standalone_rst_s5_html_2.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.19.1b.dev: https://docutils.sourceforge.io/" />
+<meta name="generator" content="Docutils 0.20b.dev: https://docutils.sourceforge.io/" />
<meta name="version" content="S5 1.1" />
<meta name="author" content="David Goodger" />
<meta name="date" content="2005-11-28" />
diff --git a/docutils/test/test__init__.py b/docutils/test/test__init__.py
index fb4d35342..434aeb529 100644
--- a/docutils/test/test__init__.py
+++ b/docutils/test/test__init__.py
@@ -74,7 +74,7 @@ class VersionInfoTests(unittest.TestCase):
"""Test that __version__ is equivalent to __version_info__."""
self.assertEqual(
docutils.utils.version_identifier(docutils.__version_info__),
- docutils.__version__)
+ docutils.__version__, f'{docutils.__version_info__} differs')
def test_version_info_comparing(self):
"""Test comparing of __version_info__ instances."""
diff --git a/sandbox/infrastructure/set_version.sh b/sandbox/infrastructure/set_version.sh
index 093eec520..6a09e4814 100755
--- a/sandbox/infrastructure/set_version.sh
+++ b/sandbox/infrastructure/set_version.sh
@@ -60,7 +60,7 @@ function set_ver()
done
set -e
echo 'Modifying docutils/__init__.py with version_identifier_parsing.py'
- python ../sandbox/infrastructure/version_identifier_parsing.py --change-version-info=docutils/__init__.py
+ python3 ../sandbox/infrastructure/version_identifier_parsing.py --change-version-info=docutils/__init__.py
fi
echo 'CAUTION: please look at the diffs carefully, for wrongly'
echo ' replaced embedded numbers.'
diff --git a/sandbox/infrastructure/version_identifier_parsing.py b/sandbox/infrastructure/version_identifier_parsing.py
index 5ae88f7c9..209e3a3bd 100755
--- a/sandbox/infrastructure/version_identifier_parsing.py
+++ b/sandbox/infrastructure/version_identifier_parsing.py
@@ -107,7 +107,7 @@ def change_version_info_definition(version, source):
with open(source) as sourcefile:
old = sourcefile.read()
if not re.search(version_info_def_pattern, old):
- return f'No matching "version_info" definition found.'
+ return 'No matching "version_info" definition found.'
new = re.sub(version_info_def_pattern, version_info_def, old)
if old == new:
return 'Nothing to change.'