summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgrubert <grubert@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2021-02-10 20:45:33 +0000
committergrubert <grubert@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2021-02-10 20:45:33 +0000
commit4361c4fe4dd98a6d8c6308e2c3b243be21eb781e (patch)
tree60e97cd654af6c93f1e076f2c4b8397efe410a71
parent380f8be071dafe1527744f0b094dbcd4b09ce76f (diff)
downloaddocutils-4361c4fe4dd98a6d8c6308e2c3b243be21eb781e.tar.gz
Set version 0.17b1
git-svn-id: https://svn.code.sf.net/p/docutils/code/trunk@8615 929543f6-e4f2-0310-98a6-ba3bd3dd1d04
-rw-r--r--docutils/HISTORY.txt2
-rw-r--r--docutils/README.txt2
-rw-r--r--docutils/docutils/__init__.py6
-rwxr-xr-xdocutils/setup.py2
-rw-r--r--docutils/test/functional/expected/compact_lists.html2
-rw-r--r--docutils/test/functional/expected/dangerous.html2
-rw-r--r--docutils/test/functional/expected/embed_images_html5.html2
-rw-r--r--docutils/test/functional/expected/field_name_limit.html2
-rw-r--r--docutils/test/functional/expected/footnotes_html5.html2
-rw-r--r--docutils/test/functional/expected/math_output_html.html2
-rw-r--r--docutils/test/functional/expected/math_output_latex.html2
-rw-r--r--docutils/test/functional/expected/math_output_mathjax.html2
-rw-r--r--docutils/test/functional/expected/math_output_mathml.xhtml2
-rw-r--r--docutils/test/functional/expected/misc_rst_html4css1.html2
-rw-r--r--docutils/test/functional/expected/pep_html.html2
-rw-r--r--docutils/test/functional/expected/standalone_rst_docutils_xml.xml2
-rw-r--r--docutils/test/functional/expected/standalone_rst_html4css1.html2
-rw-r--r--docutils/test/functional/expected/standalone_rst_html5.html2
-rw-r--r--docutils/test/functional/expected/standalone_rst_s5_html_1.html2
-rw-r--r--docutils/test/functional/expected/standalone_rst_s5_html_2.html2
-rw-r--r--sandbox/infrastructure/releasing-log.txt107
-rwxr-xr-xsandbox/infrastructure/set_version.sh2
22 files changed, 85 insertions, 68 deletions
diff --git a/docutils/HISTORY.txt b/docutils/HISTORY.txt
index f6293d493..5b05e0e2a 100644
--- a/docutils/HISTORY.txt
+++ b/docutils/HISTORY.txt
@@ -17,6 +17,8 @@
Changes Since 0.16
==================
+Version 0.17b1
+
* General
- Fix bug #385: Import of language modules.
diff --git a/docutils/README.txt b/docutils/README.txt
index 703742cc0..2977e5472 100644
--- a/docutils/README.txt
+++ b/docutils/README.txt
@@ -1,5 +1,5 @@
============================
- README: Docutils 0.17b.dev
+ README: Docutils 0.17b1
============================
:Author: David Goodger
diff --git a/docutils/docutils/__init__.py b/docutils/docutils/__init__.py
index e3f64801a..7a5d683ee 100644
--- a/docutils/docutils/__init__.py
+++ b/docutils/docutils/__init__.py
@@ -56,7 +56,7 @@ from collections import namedtuple
__docformat__ = 'reStructuredText'
-__version__ = '0.17b.dev'
+__version__ = '0.17b1'
"""Docutils version identifier (complies with PEP 440)::
major.minor[.micro][releaselevel[serial]][.dev]
@@ -115,8 +115,8 @@ __version_info__ = VersionInfo(
micro=0,
releaselevel='beta', # one of 'alpha', 'beta', 'candidate', 'final'
# pre-release serial number (0 for final releases and active development):
- serial=0,
- release=False # True for official releases and pre-releases
+ serial=1,
+ release=True # True for official releases and pre-releases
)
"""Comprehensive version information tuple. See 'Version Numbering' in
docs/dev/policies.txt."""
diff --git a/docutils/setup.py b/docutils/setup.py
index 8e74d7a31..c734252da 100755
--- a/docutils/setup.py
+++ b/docutils/setup.py
@@ -31,7 +31,7 @@ into useful formats, such as HTML, XML, and LaTeX. For
input Docutils supports reStructuredText, an easy-to-read,
what-you-see-is-what-you-get plaintext markup syntax.""", # wrap at col 60
'url': 'http://docutils.sourceforge.net/',
- 'version': '0.17b.dev',
+ 'version': '0.17b1',
'author': 'David Goodger',
'author_email': 'goodger@python.org',
'maintainer': 'docutils-develop list',
diff --git a/docutils/test/functional/expected/compact_lists.html b/docutils/test/functional/expected/compact_lists.html
index 09607d099..62220ac88 100644
--- a/docutils/test/functional/expected/compact_lists.html
+++ b/docutils/test/functional/expected/compact_lists.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<title>compact_lists.txt</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/docutils/test/functional/expected/dangerous.html b/docutils/test/functional/expected/dangerous.html
index 78374c56a..78e804a92 100644
--- a/docutils/test/functional/expected/dangerous.html
+++ b/docutils/test/functional/expected/dangerous.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<title>dangerous.txt</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/docutils/test/functional/expected/embed_images_html5.html b/docutils/test/functional/expected/embed_images_html5.html
index a8bcef150..ef724d08d 100644
--- a/docutils/test/functional/expected/embed_images_html5.html
+++ b/docutils/test/functional/expected/embed_images_html5.html
@@ -2,7 +2,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta charset="utf-8"/>
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<title>Embedded Images</title>
<link rel="stylesheet" href="../../../docutils/writers/html5_polyglot/minimal.css" type="text/css" />
<link rel="stylesheet" href="../../../docutils/writers/html5_polyglot/plain.css" type="text/css" />
diff --git a/docutils/test/functional/expected/field_name_limit.html b/docutils/test/functional/expected/field_name_limit.html
index 95e63a8ef..042bdf6e5 100644
--- a/docutils/test/functional/expected/field_name_limit.html
+++ b/docutils/test/functional/expected/field_name_limit.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<title>field_list.txt</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/docutils/test/functional/expected/footnotes_html5.html b/docutils/test/functional/expected/footnotes_html5.html
index c35333e73..949e97198 100644
--- a/docutils/test/functional/expected/footnotes_html5.html
+++ b/docutils/test/functional/expected/footnotes_html5.html
@@ -2,7 +2,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta charset="utf-8"/>
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<title>Test footnote and citation rendering</title>
<link rel="stylesheet" href="../input/data/minimal.css" type="text/css" />
<link rel="stylesheet" href="../input/data/plain.css" type="text/css" />
diff --git a/docutils/test/functional/expected/math_output_html.html b/docutils/test/functional/expected/math_output_html.html
index 6c65a9420..9dadd55a0 100644
--- a/docutils/test/functional/expected/math_output_html.html
+++ b/docutils/test/functional/expected/math_output_html.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<title>Mathematics</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
<link rel="stylesheet" href="../input/data/math.css" type="text/css" />
diff --git a/docutils/test/functional/expected/math_output_latex.html b/docutils/test/functional/expected/math_output_latex.html
index 43751cf9b..2ef92d805 100644
--- a/docutils/test/functional/expected/math_output_latex.html
+++ b/docutils/test/functional/expected/math_output_latex.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<title>Mathematics</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/docutils/test/functional/expected/math_output_mathjax.html b/docutils/test/functional/expected/math_output_mathjax.html
index 97eb2211c..04ab720f5 100644
--- a/docutils/test/functional/expected/math_output_mathjax.html
+++ b/docutils/test/functional/expected/math_output_mathjax.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<title>Mathematics</title>
<script type="text/javascript" src="/usr/share/javascript/mathjax/MathJax.js?config=TeX-AMS_CHTML"></script>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
diff --git a/docutils/test/functional/expected/math_output_mathml.xhtml b/docutils/test/functional/expected/math_output_mathml.xhtml
index 324084a66..e457ddd69 100644
--- a/docutils/test/functional/expected/math_output_mathml.xhtml
+++ b/docutils/test/functional/expected/math_output_mathml.xhtml
@@ -2,7 +2,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta charset="utf-8"/>
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<title>Mathematics</title>
<link rel="stylesheet" href="../input/data/minimal.css" type="text/css" />
<link rel="stylesheet" href="../input/data/plain.css" type="text/css" />
diff --git a/docutils/test/functional/expected/misc_rst_html4css1.html b/docutils/test/functional/expected/misc_rst_html4css1.html
index b564d4805..3af590aa4 100644
--- a/docutils/test/functional/expected/misc_rst_html4css1.html
+++ b/docutils/test/functional/expected/misc_rst_html4css1.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<title>link_in_substitution.txt</title>
<link rel="stylesheet" href="foo&amp;bar.css" type="text/css" />
</head>
diff --git a/docutils/test/functional/expected/pep_html.html b/docutils/test/functional/expected/pep_html.html
index 52838c803..5e7ff4452 100644
--- a/docutils/test/functional/expected/pep_html.html
+++ b/docutils/test/functional/expected/pep_html.html
@@ -8,7 +8,7 @@ to templates. DO NOT USE THIS HTML FILE AS YOUR TEMPLATE!
-->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
- <meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+ <meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<title>PEP 100 -- Test PEP</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/docutils/test/functional/expected/standalone_rst_docutils_xml.xml b/docutils/test/functional/expected/standalone_rst_docutils_xml.xml
index 1fc213462..030723014 100644
--- a/docutils/test/functional/expected/standalone_rst_docutils_xml.xml
+++ b/docutils/test/functional/expected/standalone_rst_docutils_xml.xml
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE document PUBLIC "+//IDN docutils.sourceforge.net//DTD Docutils Generic//EN//XML" "http://docutils.sourceforge.net/docs/ref/docutils.dtd">
-<!-- Generated by Docutils 0.17b.dev -->
+<!-- Generated by Docutils 0.17b1 -->
<document ids="restructuredtext-test-document doctitle" names="restructuredtext\ test\ document doctitle" source="functional/input/standalone_rst_docutils_xml.txt" title="reStructuredText Test Document">
<title>reStructuredText Test Document</title>
<subtitle ids="examples-of-syntax-constructs subtitle" names="examples\ of\ syntax\ constructs subtitle">Examples of Syntax Constructs</subtitle>
diff --git a/docutils/test/functional/expected/standalone_rst_html4css1.html b/docutils/test/functional/expected/standalone_rst_html4css1.html
index d1443ae23..4206ac39b 100644
--- a/docutils/test/functional/expected/standalone_rst_html4css1.html
+++ b/docutils/test/functional/expected/standalone_rst_html4css1.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<title>reStructuredText Test Document</title>
<meta name="author" content="David Goodger" />
<meta name="authors" content="Me Myself I" />
diff --git a/docutils/test/functional/expected/standalone_rst_html5.html b/docutils/test/functional/expected/standalone_rst_html5.html
index f7676ec7e..c25154c1f 100644
--- a/docutils/test/functional/expected/standalone_rst_html5.html
+++ b/docutils/test/functional/expected/standalone_rst_html5.html
@@ -2,7 +2,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta charset="utf-8"/>
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<title>reStructuredText Test Document</title>
<meta name="author" content="David Goodger" />
<meta name="author" content="Me" />
diff --git a/docutils/test/functional/expected/standalone_rst_s5_html_1.html b/docutils/test/functional/expected/standalone_rst_s5_html_1.html
index 48321aed2..fd8667cb9 100644
--- a/docutils/test/functional/expected/standalone_rst_s5_html_1.html
+++ b/docutils/test/functional/expected/standalone_rst_s5_html_1.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<meta name="version" content="S5 1.1" />
<title>Slide Shows</title>
<meta name="author" content="David Goodger" />
diff --git a/docutils/test/functional/expected/standalone_rst_s5_html_2.html b/docutils/test/functional/expected/standalone_rst_s5_html_2.html
index f4acb0817..b62abc820 100644
--- a/docutils/test/functional/expected/standalone_rst_s5_html_2.html
+++ b/docutils/test/functional/expected/standalone_rst_s5_html_2.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.17b.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.17b1: http://docutils.sourceforge.net/" />
<meta name="version" content="S5 1.1" />
<title>Slide Shows</title>
<meta name="author" content="David Goodger" />
diff --git a/sandbox/infrastructure/releasing-log.txt b/sandbox/infrastructure/releasing-log.txt
index d8caba36d..3f69e6f6e 100644
--- a/sandbox/infrastructure/releasing-log.txt
+++ b/sandbox/infrastructure/releasing-log.txt
@@ -24,76 +24,91 @@ Problems
But not for 3.8.1 on Linux .
-BetaRelease 0.17b.dev (2020-11-23) to test.pypi
-===============================================
+BetaRelease 0.17b1 (2021-02-10) to test.pypi
+============================================
-Do not change version: 0.17b.dev
+* tox with 2.7 3.8 and 3.9 ::
-``python3 setup.py clean`` tells ::
+ functional/expected/standalone_rst_html5.html
- setuptools/dist.py:473: UserWarning: Normalizing '0.17b.dev' to '0.17b0.dev0'.
+ -<dl class="footnote brackets">
+ ...
+ -<dd><p>Requires support for attributes to inline
+ -roles to make sense.</p>
+ -</dd>
+ -</dl>
-TODO check on version numbering
+ seams to be a moved chunk in test input but not in expected
-test ::
+* Version numbering
- export PYTHONPATH=.
- export PYTHONWARNINGS=default
- python2 test/alltests.py
+ ``python3 setup.py clean`` tells ::
-``python3 test/alltests.pypython3`` has some DeprecationWarning::
+ setuptools/dist.py:473: UserWarning: Normalizing '0.17b.dev' to '0.17b0.dev0'.
- docutils/utils/smartquotes.py:639: DeprecationWarning: invalid escape sequence \[
- ch_classes = {'open': u'[(\[{]', # opening braces
+ Acchording to https://www.python.org/dev/peps/pep-0440/#pre-releases
- docutils/parsers/rst/directives/images.py:145: ResourceWarning:
- unclosed file <_io.BufferedReader name=b'../docs/user/rst/images/title.png'>
- del img
+ set_version 0.17b1
- docutils/writers/html4css1/__init__.py:570: ResourceWarning:
- unclosed file <_io.BufferedReader name=b'../docs/user/rst/images/biohazard.png'>
- del img
+* test ::
-YET TODO
+ export PYTHONPATH=
+ export PYTHONWARNINGS=default
+ python2 test/alltests.py
- ``invalid escape sequence \[`` does not come always ???
+ Ran 1454 tests
+ OK (skipped=3)
-Upload universal wheel and source to test.pypi::
+ python3 test/alltests.py
+ Ran 1442 tests
+ OK (skipped=5)
- python3 setup.py sdist
- python3 setup.py bdist_wheel --universal
- python3 -m twine upload --repository-url https://test.pypi.org/legacy/ dist/*
+ python has some ResourceWarning::
-Wait some minutes to test in virtualenv ::
+ docutils/parsers/rst/directives/images.py:145: ResourceWarning:
+ unclosed file <_io.BufferedReader name=b'../docs/user/rst/images/title.png'>
+ del img
- python2 -m virtualenv du2 ; cd du2
- export PYTHONPATH= ; . bin/activate
+ docutils/writers/html4css1/__init__.py:578: ResourceWarning:
+ unclosed file <_io.BufferedReader name=b'../docs/user/rst/images/biohazard.png'>
+ del img
- python -m pip install --index-url https://test.pypi.org/simple/ --no-deps docutils
- # Successfully installed docutils-0.16
+* Upload universal wheel and source to test.pypi::
- cp -r ~/projects/docutils-code/docutils/test .
- python2 test/alltests.py
- # IGNORE stylesheet path differences ?
+ python3 setup.py sdist
+ python3 setup.py bdist_wheel --universal
+ python3 -m twine upload --repository-url https://test.pypi.org/legacy/ dist/*
- python -m pip uninstall docutils
- deactivate ; cd .. ; rm -rf du2
+ Wait some minutes to test in virtualenv ::
-Test in venv ::
+ python2 -m virtualenv du2 ; cd du2
+ export PYTHONPATH= ; . bin/activate
- python3 -m venv du3 ; cd du3
- export PYTHONPATH= ; . bin/activate
+ python -m pip install --index-url https://test.pypi.org/simple/ --no-deps --pre docutils
+ # Successfully installed docutils-0.17b1
- python3 -m pip install --index-url https://test.pypi.org/simple/ --no-deps docutils
- # Successfully installed docutils-0.16
+ cp -r ~/projects/docutils-code/docutils/test .
+ # copy docs too for inlined images to be found
+ python2 test/alltests.py
+ # IGNORE stylesheet path differences ?
- cp -r ~/projects/docutils-code/docutils/test .
- python test/alltests.py
- # IGNORE stylesheet path differences ?
- # FAIL: test_find_file_in_dirs (test_utils.HelperFunctionTests)
- # FAIL: test_rst/ interpreted directives/code ...
- # classes="keyword" is "name builtin" in 3.8.0b3 on Darwin 15.6.0
+ deactivate ; cd .. ; rm -rf du2
+
+ Test in venv ::
+
+ python3 -m venv du3 ; cd du3
+ export PYTHONPATH= ; . bin/activate
+
+ python3 -m pip install --index-url https://test.pypi.org/simple/ --no-deps --pre docutils
+ # Successfully installed docutils-0.17b1
+
+ cp -r ~/projects/docutils-code/docutils/test .
+ cp -r ~/projects/docutils-code/docutils/docs .
+ python test/alltests.py
+ # Python 3.8.5 Linux 5.4.0
+ # IGNORE stylesheet path differences ?
+* commit 0.17b1 to code.sf
Release 0.16 (2020-01-12)
=========================
diff --git a/sandbox/infrastructure/set_version.sh b/sandbox/infrastructure/set_version.sh
index b98f3810c..093eec520 100755
--- a/sandbox/infrastructure/set_version.sh
+++ b/sandbox/infrastructure/set_version.sh
@@ -30,7 +30,7 @@ if [ -z "$1" ] ; then
exit
fi
-old_ver="`python -c 'import docutils; print docutils.__version__'`"
+old_ver="`python3 -c 'import docutils; print(docutils.__version__)'`"
new_ver=$1
echo "from current Docutils version ${old_ver} to ${new_ver}"