summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormilde <milde@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2023-04-21 17:41:17 +0000
committermilde <milde@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2023-04-21 17:41:17 +0000
commit505926e5a26ee39327c88e54f89d558b15f43061 (patch)
tree3e9f4fe9eef4e8cf02cf72e56e23f6a3146a3ee4
parent3d9529bd2f71fadd9e6edf858cb161418cc62d8a (diff)
downloaddocutils-505926e5a26ee39327c88e54f89d558b15f43061.tar.gz
Last documentation edits for 0.20 release.
Review and small corrections to HISTORY and RELEASE-NOTES. Add comment with rationale for future cvs-table changes. git-svn-id: https://svn.code.sf.net/p/docutils/code/trunk@9362 929543f6-e4f2-0310-98a6-ba3bd3dd1d04
-rw-r--r--docutils/HISTORY.txt7
-rw-r--r--docutils/RELEASE-NOTES.txt6
-rw-r--r--docutils/docutils/parsers/rst/directives/tables.py19
3 files changed, 25 insertions, 7 deletions
diff --git a/docutils/HISTORY.txt b/docutils/HISTORY.txt
index 8fcc9b9b9..a55c7b815 100644
--- a/docutils/HISTORY.txt
+++ b/docutils/HISTORY.txt
@@ -26,6 +26,7 @@ Release 0.20 (unpublished)
- New argument "auto_encode" for `publish_string()`,
`publish_from_docstring()` and `publish_programmatically()`.
- New functions `rst2…()` for use as "console_scripts" `entry points`_.
+ (cf. `Future changes` in the RELEASE-NOTES_).
* docutils/frontend.py
@@ -82,7 +83,7 @@ Release 0.20 (unpublished)
* docutils/utils/math/latex2mathml.py
- - Support "mod" notation for modulo operation/modulus arithmetic.
+ - Support "mod" notation for modulo operation / modulus arithmetic.
* docutils/utils/math/tex2mathml_extern.py
@@ -126,8 +127,8 @@ Release 0.20 (unpublished)
* docutils/writers/xetex/__init__.py
- - Ignore settings in the [latex2e writer] configuration file section
- (users can place common settings in section [latex writers]).
+ - Ignore settings in the [latex2e writer] configuration file section.
+ Place common settings in section [latex writers].
* setup.py
diff --git a/docutils/RELEASE-NOTES.txt b/docutils/RELEASE-NOTES.txt
index 858ce2086..5d42f2738 100644
--- a/docutils/RELEASE-NOTES.txt
+++ b/docutils/RELEASE-NOTES.txt
@@ -206,11 +206,15 @@ Release 0.20 (unpublished)
Use dpub-ARIA role "doc-footnote" (instead of ARIA role "note")
for footnotes.
+ LaTeX:
+ Do not load the `inputenc` package in UTF-8 encoded LaTeX sources.
+ (UTF-8 is the default encoding for LaTeX2e since 2018).
+
* Configuration changes:
- Settings in the [latex2e writer] configuration file section
are now ignored by the "xetex" writer.
- Users can place common settings in section `[latex writers]`_.
+ Place common settings in section `[latex writers]`_.
.. _[latex writers]: docs/user/config.html#latex-writers
diff --git a/docutils/docutils/parsers/rst/directives/tables.py b/docutils/docutils/parsers/rst/directives/tables.py
index 328554da1..446034828 100644
--- a/docutils/docutils/parsers/rst/directives/tables.py
+++ b/docutils/docutils/parsers/rst/directives/tables.py
@@ -234,12 +234,25 @@ class CSVTable(Table):
super().__init__()
class HeaderDialect(csv.Dialect):
-
- """CSV dialect used for the "header" option data.
+ """
+ CSV dialect used for the "header" option data.
Deprecated. Will be removed in Docutils 0.22.
"""
-
+ # The separate HeaderDialect was introduced in revision 2294
+ # (2004-06-17) in the sandbox before the "csv-table" directive moved
+ # to the trunk in r2309. Discussion in docutils-devel around this time
+ # did not mention a rationale (part of the discussion was in private
+ # mail).
+ # This is in conflict with the documentation, which always said:
+ # ""
+ # and did not change in this aspect.
+ #
+ # Maybe it was intended to have similar escape rules for rST and CSV,
+ # however with the current implementation this means we need
+ # `\\` for rST markup and ``\\\\`` for a literal backslash
+ # in the "option" header but ``\`` and ``\\`` in the header-lines and
+ # table cells of the main CSV data.
delimiter = ','
quotechar = '"'
escapechar = '\\'