summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgrubert <grubert@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2022-07-05 20:44:18 +0000
committergrubert <grubert@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2022-07-05 20:44:18 +0000
commit5938461c64dae3ac01029d3fc835dab8d04f019c (patch)
tree79d3db2cb084da05ff2dfd79d5b28bb455256d81
parent1affffe9c17b461f7d5b59a56c1a0f9dd0318f75 (diff)
downloaddocutils-5938461c64dae3ac01029d3fc835dab8d04f019c.tar.gz
releasing 0.19
git-svn-id: https://svn.code.sf.net/p/docutils/code/trunk@9106 929543f6-e4f2-0310-98a6-ba3bd3dd1d04
-rw-r--r--sandbox/infrastructure/releasing-log.txt116
1 files changed, 114 insertions, 2 deletions
diff --git a/sandbox/infrastructure/releasing-log.txt b/sandbox/infrastructure/releasing-log.txt
index 66a47d2f6..8b71c681e 100644
--- a/sandbox/infrastructure/releasing-log.txt
+++ b/sandbox/infrastructure/releasing-log.txt
@@ -8,8 +8,120 @@ Releasing
Notes on what happend while releasing.
-Problems
-========
+Release 0.19 (2022-07-05)
+=========================
+
+(follow docs/dev/release.txt)
+
+* svn update
+* run tox
+* run tests with py3.6 to 3.11
+
+* Update RELEASE-NOTES.txt add section ``Release <version>``.
+
+ Consult HISTORY.txt for important changes.
+
+* Change HISTORY.txt title ``Changes Since <previous release>`` to ``Release <version>``.
+
+* Set new version with ``sandbox/infrastructure/set_version.sh <version>``
+
+ Check what was changed with version control system by ``set_version.sh``
+
+ Change docutils/__init__.py __version_info__ tuple.
+
+ Run tests ::
+
+ export PYTHONWARNINGS=default
+ python3 test/alltests.py
+
+ or use tox.
+
+ ``export PYTHONWARNINGS=default`` prints DeprecationWarnings in python3.
+
+* Generate wheel and source-distribution::
+
+ python3 setup.py sdist
+ python3 setup.py bdist_wheel
+
+* Upload wheel and source to test.pypi::
+
+ python3 -m twine upload --repository-url https://test.pypi.org/legacy/ dist/*
+
+ Test in venv. NOTE use --pre for prereleases::
+
+ python3 -m venv du3 ; cd du3
+ export PYTHONPATH= ; . bin/activate
+
+ python -m pip install --index-url https://test.pypi.org/simple/ --no-deps docutils
+
+ cp -Lr ../docutils-code/docutils/test .
+ python test/alltests.py
+
+ python -m pip uninstall docutils
+ deactivate ; cd .. ; rm -r du3
+
+* Commit changes ... the changed version number.
+
+* tag 0.## (Note: only directory docutils is copied)::
+
+ svn copy svn+ssh://grubert@svn.code.sf.net/p/docutils/code/trunk/docutils \
+ svn+ssh://grubert@svn.code.sf.net/p/docutils/code/tags/docutils-0.19 \
+ -m "tagging release 0.19"
+
+* Update your source directory.
+* Rebuild wheel and source-distribution ::
+
+ python3 setup.py sdist
+ python3 setup.py bdist_wheel
+
+* Now upload to pypi::
+
+ python3 -m twine upload dist/docutils-0.19*
+
+* Remove previous package from local cache::
+
+ find .cache/pip/wheels -name docutils\*whl -exec rm -v -i {} \;
+
+* and test::
+
+ python3 -m venv du3 ; cd du3
+ export PYTHONPATH= ; . bin/activate
+
+ pip install --no-deps docutils
+ cp -Lr ../docutils-code/docutils/test .
+ python test/alltests.py
+
+ deactivate ; cd .. ; rm -r du3
+
+* Notify to docutils-developer and user.
+
+* upload source and generated html to sf-htdocs/0.19 ::
+
+ mkdir tmp1
+ cd tmp1
+ tar xzvf ../dist/docutils-0.19.tar.gz
+ cd docutils-0.19/
+ tools/buildhtml.py .
+ find . -name \*.pyc -exec rm -v {} \;
+ find . -name __pycache__ -exec rmdir -v {} \;
+ rm -r docutils.egg-info
+ rsync -e ssh -r -t ./ web.sourceforge.net:/home/project-web/docutils/htdocs/0.19
+
+* Check web/index.txt for necessary corrections.
+* Run sandbox/infrastructure/docutils-update.local to update web-content.
+* Release to sourceforge.
+
+ - Upload tar.gz and 0.19 release notes to sourceforge.
+ - Select docutils-0.19.tar.gz as default for all OS.
+
+* set_version 0.19.1b.dev
+* test with py3
+* docutils/HISTORY.txt: add title "Changes Since 0.##"
+* svn commit
+* run sandbox/infrastructure/docutils-update.local
+
+Problems while releasing 0.19b1
+===============================
* If docutils is installed into virtual environment and
the test directory is copied from development directory