summaryrefslogtreecommitdiff
path: root/install.py
diff options
context:
space:
mode:
Diffstat (limited to 'install.py')
-rwxr-xr-xinstall.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/install.py b/install.py
new file mode 100755
index 000000000..1a71e433f
--- /dev/null
+++ b/install.py
@@ -0,0 +1,27 @@
+#!/usr/bin/env python
+# $Id$
+# Copyright: This file has been placed in the public domain.
+
+"""
+This is a quick & dirty installation shortcut. It is equivalent to the
+command::
+
+ python setup.py install
+
+However, the shortcut lacks error checking and command-line option
+processing. If you need any kind of customization or help, please use
+one of::
+
+ python setup.py install --help
+ python setup.py --help
+"""
+
+from distutils import core
+from setup import do_setup
+
+if __name__ == '__main__' :
+ print __doc__
+ core._setup_stop_after = 'config'
+ dist = do_setup()
+ dist.commands = ['install']
+ dist.run_commands()