summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorHubert Kario <hkario@redhat.com>2018-09-04 19:18:24 +0200
committerHubert Kario <hkario@redhat.com>2018-09-04 22:56:03 +0200
commit197362b8e6190d1dcfba9ce131f970816474393b (patch)
treee1610a5381a00ffbb42a00e70c6e51104319b22d /tox.ini
parent2ba6477f761c715ed4564346ed815edaccf96789 (diff)
downloadecdsa-197362b8e6190d1dcfba9ce131f970816474393b.tar.gz
fix tox config, make tests pass on Python3.3
coverage should be used to run the tests on all architectures, including with local run on py33 install older packages compatible with it
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini15
1 files changed, 8 insertions, 7 deletions
diff --git a/tox.ini b/tox.ini
index 3adbc45..0399271 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,16 +1,18 @@
[tox]
-envlist = py26, py27, py33, py34, py35, py36
+envlist = py26, py27, py33, py34, py35, py36, pypy, pypy3
[testenv]
deps =
- pytest
-commands = py.test {posargs:src/ecdsa}
+ py{33}: py<1.5
+ py{33}: pytest<3.3
+ py{26,27,34,35,36,py,py3}: pytest
+ py{33}: wheel<0.30
+ coverage
+commands = coverage run --branch -m pytest {posargs:src/ecdsa}
[testenv:coverage]
-deps =
- coverage
- pytest
+sitepackages=True
commands = coverage run --branch -m pytest {posargs:src/ecdsa}
[testenv:speed]
@@ -24,7 +26,6 @@ deps =
commands =
flake8 setup.py speed.py src
-
[flake8]
exclude = src/ecdsa/test*.py
# We're just getting started. For now, ignore the following problems: