summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorHubert Kario <hubert@kario.pl>2020-11-09 13:20:49 +0100
committerHubert Kario <hubert@kario.pl>2020-11-09 13:35:44 +0100
commit38e52532564c72529e610d2ae3f8fca55ebdc158 (patch)
tree03c7da3a7c9c3540308cbc232f8219a52848fbc1 /tox.ini
parentfe62ed31889c451b59b9c1654c2d9f21809e7ce2 (diff)
downloadecdsa-38e52532564c72529e610d2ae3f8fca55ebdc158.tar.gz
add testing on python 3.9
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini22
1 files changed, 11 insertions, 11 deletions
diff --git a/tox.ini b/tox.ini
index 612145b..6ea424f 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
-envlist = py26, py27, py33, py34, py35, py36, py37, py38, py, pypy, pypy3, gmpy2py27, gmpy2py38, gmpypy27, gmpypy38, codechecks
+envlist = py26, py27, py33, py34, py35, py36, py37, py38, py39, py, pypy, pypy3, gmpy2py27, gmpy2py39, gmpypy27, gmpypy39, codechecks
[testenv]
deps =
@@ -10,12 +10,12 @@ deps =
py{33}: hypothesis<3.44
py{26}: unittest2
py{26}: hypothesis<3
- py{26,27,34,35,36,37,38,py,py3}: pytest
- py{27,34,35,36,37,38,py,py3}: hypothesis
- gmpy2py{27,38}: gmpy2
- gmpypy{27,38}: gmpy
- gmpy{2py27,2py38,py27,py38}: pytest
- gmpy{2py27,2py38,py27,py38}: hypothesis
+ py{26,27,34,35,36,37,38,39,py,py3}: pytest
+ py{27,34,35,36,37,38,39,py,py3}: hypothesis
+ gmpy2py{27,39}: gmpy2
+ gmpypy{27,39}: gmpy
+ gmpy{2py27,2py39,py27,py39}: pytest
+ gmpy{2py27,2py39,py27,py39}: hypothesis
# six==1.9.0 comes from setup.py install_requires
py27_old_six: six==1.9.0
py27_old_six: pytest
@@ -46,14 +46,14 @@ basepython = python2.7
[testenv:gmpypy27]
basepython=python2.7
-[testenv:gmpypy38]
-basepython=python3.8
+[testenv:gmpypy39]
+basepython=python3.9
[testenv:gmpy2py27]
basepython=python2.7
-[testenv:gmpy2py38]
-basepython=python3.8
+[testenv:gmpy2py39]
+basepython=python3.9
[testenv:coverage]
sitepackages=True