summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorHubert Kario <hkario@redhat.com>2019-11-29 15:07:57 +0100
committerHubert Kario <hkario@redhat.com>2019-11-29 15:55:49 +0100
commit6c4f8cb35ba4fe67063f1497c596329928d9d7aa (patch)
treeb4d21ea74059dd044bf714b58114a674e8f6df02 /tox.ini
parent9b62c8efa3feb11451cf88a0dc92514d51188537 (diff)
downloadecdsa-6c4f8cb35ba4fe67063f1497c596329928d9d7aa.tar.gz
six: expect specific version
since we use features introduced in 1.9.0, we require it for installation/use also add test coverage to ensure we update that version when we need something newer
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini7
1 files changed, 7 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
index fbaf823..0b3bcda 100644
--- a/tox.ini
+++ b/tox.ini
@@ -12,12 +12,19 @@ deps =
py{26}: hypothesis<3
py{26,27,34,35,36,37,38,py,py3}: pytest
py{27,34,35,36,37,38,py,py3}: hypothesis
+# six==1.9.0 comes from setup.py install_requires
+ py27_old_six: six==1.9.0
+ py27_old_six: pytest
+ py27_old_six: hypothesis
py: pytest
py: hypothesis
py{33}: wheel<0.30
coverage
commands = coverage run --branch -m pytest {posargs:src/ecdsa}
+[testenv:py27_old_six]
+basepython = python2.7
+
[testenv:coverage]
sitepackages=True
commands = coverage run --branch -m pytest --hypothesis-show-statistics {posargs:src/ecdsa}