summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorHubert Kario <hubert@kario.pl>2021-05-04 02:39:51 +0200
committerHubert Kario <hubert@kario.pl>2021-05-21 00:11:06 +0200
commit77cabc01acc02d96b83c1bbb7b91b5447393286e (patch)
tree81cc2b5d8bf02897345ac2650fe3fb7809dab00a /tox.ini
parent717c04cad4ccc6441a644530a847d611adb2d1e2 (diff)
downloadecdsa-77cabc01acc02d96b83c1bbb7b91b5447393286e.tar.gz
add tox environment for formatting code with black
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini7
1 files changed, 7 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
index 742f3fb..1550ac5 100644
--- a/tox.ini
+++ b/tox.ini
@@ -96,6 +96,13 @@ commands =
flake8 setup.py speed.py src
black --check --line-length 79 .
+[testenv:codeformat]
+basepython = python3
+deps =
+ black==19.10b0
+commands =
+ black --line-length 79 .
+
[flake8]
exclude = src/ecdsa/test*.py
# We're just getting started. For now, ignore the following problems: